Doing a search with no keywords loads an invalid page [caused by Google Toolbar]

VERIFIED INVALID

Status

()

Firefox
Extension Compatibility
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Norman Rasmussen, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6 (.NET CLR 3.5.30729)

Searching the Google with a blank entry makes the rlz entry add incorrectly.

Reproducible: Always

Steps to Reproduce:
1. Clear search string in 'quick'-search toolbar entry
2. Press enter
3.
Actual Results:  
http://www.google.com/firefox&rlz=1R1GGGL_en is loaded

Expected Results:  
http://www.google.com/firefox?rlz=1R1GGGL_en should be loaded (notice the & changes to ?)

also see: http://www.google.com/support/forum/p/Toolbar/thread?tid=7e686c7e289a37ef&hl=en
Gavin or Flint, can you reproduce this issue? While testing in Europe it works fine because there are no parameters in the URL.
Sounds like a problem caused by Google Toolbar, from reading that thread? The default Firefox search bar doesn't use the "rlz" parameter at all.
(Reporter)

Comment 3

9 years ago
ahh, 100% I will follow up with Google instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 4

9 years ago
I work on the Google Toolbar team, and we're working to resolve this bug. I'll update our known issues page when this is fixed: 

http://www.google.com/support/toolbar/bin/static.py?hl=en&page=known_issues.cs 

In the meantime, Google Toolbar users can click the "Google" logo button to the left of the Google Toolbar's search box to visit Google.com.
Thanks Brian!
Status: RESOLVED → VERIFIED
Component: Search → Extension Compatibility
QA Contact: search → extension.compatibility
Summary: Doing a search with no keywords loads an invalid page → Doing a search with no keywords loads an invalid page [caused by Google Toolbar]
Version: unspecified → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.