Link without any effect

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
18 years ago

People

(Reporter: j, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test9 i686; en-US; m18) Gecko/20001001
BuildID:    2000100109

Links are not followed.

Reproducible: Always
Steps to Reproduce:
			Click on any town (Paris, Bordeaux...) . The goreg() function is called but has no
effect and the frame content is never updated.				

Actual Results:  					Nothing		

Expected Results:  				Follow the link

Comment 1

19 years ago
The given URL contains four frames. The 3rd and 4th are subframes of the 2nd:


URL http://www.ugc.fr/ugc1/html/1_0_up.htm
    FRAME http://www.ugc.fr/ugc1/html/1_0_up.htm
    FRAME http://www.ugc.fr/ugc1/html/1_0_1.htm
        FRAME http://www.ugc.fr/ugc1/html/1_0_main.htm
        FRAME http://www.ugc.fr/ugc1/html/1_0_down.htm



The function goreg() in inside 1_0_main.htm: 


function goreg(url,region,sousregion)
{var adresse = 
'/ugc1/bin/setregion.pgi?region='+escape(region)+'&sousregion='+escape(sousregio
n)+'&url='+escape(url);
 parent.location=adresse;
}



So, it is trying to set parent.location to a relative URL from inside a frame. 
Therefore I think this might be a duplicate of bug 49312, which involves 
the same idea, only with window.location... 


But I will let the DOM experts decide. Reassigning to DOM Level 0 for 
further triage -
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 2

19 years ago
Oops - I included an extra "up" at the top of the HTML diagram above. 
Please ignore that; at the top should just be the given URL:
 
                 http://www.ugc.fr/ugc1/html/1_0.htm
 

Comment 3

19 years ago
Using Mozilla binary 2000093009 on WinNT, 2000092909 on Linux.
Verifying bug on both; changing OS to "All".


More evidence for the diagnosis:


Using Mozilla, click on the link for the frame in question:

            http://www.ugc.fr/ugc1/html/1_0_main.htm


Then clicking on any link there seems to work. But if you use Mozilla on the
given parent URL, the same links (now appearing in a sub-frame) do not work.


NOTE: I have Mozilla set to disable cookies. If you don't do that,
      you may only get to see the parent URL once in its original state.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
(Assignee)

Comment 4

18 years ago
Hmm, tried on WinNT and Linux, branch and trunk, but no luck, WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.