use google search when entering a single keyword instead of I'm feeling Lucky

RESOLVED DUPLICATE of bug 565966

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 565966
9 years ago
9 years ago

People

(Reporter: wvw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6

When entering one word in the (smart) locationbar, e.g. 'foo', ffox tries to resolve the server with the exact same name or uses Google's I'm feeling lucky service. But on the other side, when entering a couple of words seperated by spaces, ffox sends the user to the normal Google search. This is strange (and not smart). The Chrome/Iron browsers do use the Google normal search, which is more logical, predictable and moer userfriendly. And under the Google deal, it would probably also generate more cash for the Mozilla foundation.

Reproducible: Always

Steps to Reproduce:
1. Type in 'foo' in the locationbar.
2. Ffx will search for the server 'foo'
3. It won't find it (in my network, and in 99.999% of all networks), but it takes a lot of time

Actual Results:  
It takes a lot of time and Ffx will send you to http://en.wikipedia.org/wiki/Foobar

Expected Results:  
Don't try to resolve the server 'foo' (eats up my time), and take the user directly to http://www.google.nl/search?q=foo (or the Yahoo or Bing alternative?)

Updated

9 years ago
Blocks: 565966
Count this as a vote against. (Bug 48570, on the other hand, could use fixing...)
Since there's a patch to do this over in bug 565966, I'm duping this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565966
No longer blocks: 565966
You need to log in before you can comment on or make changes to this bug.