Closed Bug 549573 Opened 10 years ago Closed 1 year ago

when deleting with last message in mailbox would prefer message window closes

Categories

(Penelope Graveyard :: Mail Window, enhancement)

Other
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: it8purple, Assigned: mdudziak)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.9 (KHTML, like Gecko) Chrome/5.0.307.11 Safari/532.9
Build Identifier: 8.0b8

After I hit delete on the last message in my mail box my message window remains open.  I'd rather it go away.   I'd like to suggest an option setting to allow users to configure this behavior.

Reproducible: Always

Steps to Reproduce:
1.set preference to open message in : an existing message window
2.read last message in mail box
3.delete it.  next to last message is displayed.


Expected Results:  
I'd like to be able to configure the app  to close the message window when I delete the last message in a mail box.
I can see where if you delete the last message in a mailbox such that there are no more messages _at all_ in the mailbox that it would be nice to close the window, but if there are other messages to select in the mailbox I think it is appropriate for them to get selected/displayed.

Leaving open to see what other people think.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I couldn't reproduce above situation with "open in existing message window" but the same thing happens with "open in a new tab" and option "close message window on move or delete" is checked.

Version: OSE v1.0

Reproducible: Always

1. open any mail in a tab
2. delete it
3. next mail (or previous if deleted mail was the last) is opened, regardless of if it is read or not


Expected Results:

Deleting mail should open next UNREAD mail or if there is not any unread mail, close the tab
Penelope didn't see any activity in the vcs for the last 8 years, closing.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.