[HTML5][Patch] Atom staticness checks lack a negation

RESOLVED FIXED

Status

()

Core
HTML: Parser
P1
normal
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: hsivonen, Assigned: hsivonen)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 429701 [details] [diff] [review]
Add negations to the faulty |if| conditions

There are three places in the HTML5 parser where the IsStaticAtom() method call in an |if| condition lacks a negation. Spun off from bug 534136 comment 62.

(I'm unable to write steps to reproduce that'd show an observable failure due to this bug.)
Attachment #429701 - Flags: review?(jonas)
(Assignee)

Updated

8 years ago
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Priority: -- → P1
(Assignee)

Comment 1

8 years ago
http://hg.mozilla.org/mozilla-central/rev/ee11295395a5
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.