Very inefficient use of menu shortcuts as a result of Icelandic (IS) translation.

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: 2devnull, Assigned: kristjanbjarni)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; is; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird

The use of menu shortcuts are next to unusable because the translation seems to have altered many, or most, of the shortcut letters used in the English version.

Example 1:
Using what was ALT+E (Edit) before, is now ALT+B (Breyta). To me the proper thing to do would be to break as few shortcuts as possible. 

Example 2: When you look through the options in Edit menu (Breyta), you'll find that the keyboard shortcut L is used for FOUR different options!!! These are namely "Líma" (Paste), "Líma inn sem tilvitnun" (Paste as quotation), "Línuskipta..." (Hyphenate?) and "Leita og víxla" (Find and replace).

Reproducible: Always

Steps to Reproduce:
NOTE: THIS IS ONLY ONE EXAMPLE:

1. Press ALT + B (Breyta) (This is ALT+E, Edit, in the English version)
2. Notice the letter 'L' is underlined for FOUR different options.
3. Choosing one of the four means you need to press 'L' until you arrive at the one you want to use.
Actual Results:  
Getting what you want in a menu through use of keyboard shortcuts is very inefficient and annoying.

Expected Results:  
Pressing only ALT+'somekey', then 'someotherkey' should be enough to get what you want.

When working on translation I've generally seen strings like "&Edit". Instead of translating it to "&Breyta" the preferred policy, at least from my perspective of keeping usability intact, it should be translated to "Br&eyta".

@Icelandic-Translators: Please make a BIG note of the use of '&' in the strings. They do make all the difference when ensuring usability through keyboard shortcuts.

For me this is a complete show-stopper. I cannot use Thunderbird in Icelandic while this is not fixed, or at least remedied to decrease the number of SAME-LETTER options within a single menu.
(Assignee)

Comment 1

9 years ago
Hi 2devnull

Actually I have tried to use the same English key in most places where possible, however I have also preferred consistency for general menu items as a priority. For example "Afrita", "Líma", "Klippa" ,"Prenta", "Hætta", "Loka" and etc. This if course means that other keys sometimes have to be changed if there is a conflict. Most changes are simply because the translation doesn't have the same shortcut key in English or had to be changed because some other translation had too few characters to select from.

But of course in some places the shortcut keys are simply wrong and repeated as you have noticed. I will change the "Breyta" shortcut to "E" (Although I know some prefer the main menu to have the shortcut on the first possible letter) and I have gone over the translation and fixed where the same shortcuts where used.

Thanks for your comments. Improvements will be in the next update of Thunderbird 3.0.4 in Icelandic.

kveðja
 - Kristján
Assignee: nobody → kristjanbjarni
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

9 years ago
Takk fyrir þetta Kristján. 

Ég er með TB á ensku eins og er, en prófa þetta aftur síðar. Það stakk mig mest þegar sami bókstafurinn er notaður mörgum sinnum í sömu valmynd, sem ætti aldrei að þurfa nema aðeins ef valmyndin er þeim mun flóknari og viðameiri :-)

Gaman að sjá íslenskuna í þessu samt og ég geri mér fulla grein fyrir því að þýðingar á svona forritum eru alls ekki auðveldar.

--Finnbogi
You need to log in before you can comment on or make changes to this bug.