Closed Bug 549630 Opened 10 years ago Closed 10 years ago

unexpected horizontal line repaint issue in pull-down menulist

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: alice0775, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100301 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100302 Minefield/3.7a3pre ID:20100302035357

Option > Apprications pane
When i mouse over pull-down list of actionsMenu, unexpected horizontal line will remain.

Reproducible: Always

Steps to Reproduce:
1.Start Minefield with New profile
2.Option > Apprications pane
3.Mouse over pull-down list of actionsMenu

Actual Results:  
unexpected horizontal line will remain


Expected Results:  
No unexpected horizontal line


regression window:

works:
http://hg.mozilla.org/mozilla-central/rev/37dc1ce4708d
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100228 Minefield/3.7a3pre ID:20100228212929

fails:
http://hg.mozilla.org/mozilla-central/rev/1cfa33c0e178
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100301 Minefield/3.7a3pre ID:20100301011935

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=37dc1ce4708d&tochange=1cfa33c0e178
candidate:
Bug 534425 -  (layers) Create basic layers infrastructure
Blocks: layers
Keywords: regression
Version: unspecified → Trunk
There is a problem in another place.
option > privacy pane > When using the location bar, suggest:
Assignee: nobody → roc
blocking2.0: --- → ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Are those attached examples running with Aero 'off' ?  I don't see any lines in drop downs with Aero on on my Win7 machine, and the images look like the old windows 'classic' that I thought was dropped from Win7.
(In reply to comment #4)
> Are those attached examples running with Aero 'off' ?  I don't see any lines in
> drop downs with Aero on on my Win7 machine, and the images look like the old
> windows 'classic' that I thought was dropped from Win7.

It happens not only with 'classic' but also with 'Aero' windows7 visual style.
And it happens with 'classic'on Windows XP too.
The third example is on Windows XP and with the 'Classic' theme, so no D2D stuff what so ever. A bit frustrating that a change to do D2D for Win7/Vista impacts XP in this way, but maybe the layers stuff will bring optimization to XP later?
(In reply to comment #6)
> A bit frustrating that a change to do D2D for Win7/Vista
> impacts XP in this way, but maybe the layers stuff will bring optimization to
> XP later?

Layers is what caused this, not d2d.  Look at the regression range that Alice obtained.
But layers where introduced to do D2D, or will layers also improve things on WinXP (still the largest user base of Firefox)?
We will have layers on Windows XP, yes, at least for some kinds of hardware. In fact layers will bring improvements even for users with no special graphics hardware. However, that is not relevant to this bug.
Good! Note, Shredder also has this problem now:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3pre) Gecko/20100303 Lightning/1.1a1pre Shredder/3.2a1pre
Attached patch fixSplinter Review
mViewToWidgetOffset is calculated the wrong way around. I don't know why we only noticed this now.
Attachment #430494 - Flags: review?(matspal)
Whiteboard: [needs review]
Comment on attachment 430494 [details] [diff] [review]
fix

r=mats (except nsprpub/configure)

I'm also puzzled why we didn't see this before bug 534425 -
was/is there a second bug somewhere that neutralizes this one
that got fixed/wallpapered by bug 534425?

The code is the same on 1.9.2; I applied the patch there and
it caused a new problem (same STR as comment 0, then resize
the pref window and click on the Action drop-down) - the 1px
wide area left of the menu isn't repainted (on Linux).
Attachment #430494 - Flags: review?(matspal) → review+
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [needs review]
FYI, it looks like this code came from bug 380438; I pushed reftests
for a couple of its regression bugs (bug 381746 and bug 383035).
(In reply to comment #12)
> (From update of attachment 430494 [details] [diff] [review])
> r=mats (except nsprpub/configure)
> 
> I'm also puzzled why we didn't see this before bug 534425 -
> was/is there a second bug somewhere that neutralizes this one
> that got fixed/wallpapered by bug 534425?

I'm not really sure, it's a bit disturbing.

Thanks for pushing the reftests. I'm not sure how to test this bug, unfortunately.
Whiteboard: [needs landing]
Can the patch be committed?
http://hg.mozilla.org/mozilla-central/rev/def0545f8384
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
Verified fixed using nightly build Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100315 Minefield/3.7a3pre
Status: RESOLVED → VERIFIED
blocking2.0: ? → final+
Priority: -- → P2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100422 Minefield/3.7a5pre
(In reply to comment #1)
> Created an attachment (id=429738) [details]
> unexpected holizontal line will remain

(In reply to comment #2)
> Created an attachment (id=429742) [details]
> unexpected horizontal line in option > privacy pane
> 
> There is a problem in another place.
> option > privacy pane > When using the location bar, suggest:

The abobe problem happens again on Clean profile of
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100423 Minefield/3.7a5pre ID:20100423040128.
New regression window for comment #21

Works:
http://hg.mozilla.org/mozilla-central/rev/560eb81389cc
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100422 Minefield/3.7a5pre ID:20100422172405

Fails:
http://hg.mozilla.org/mozilla-central/rev/a9ec36359a4c
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100422 Minefield/3.7a5pre ID:20100422211905

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=560eb81389cc&tochange=a9ec36359a4c

May  i reopen this bug OR create new bug?
I filed Bug 561388  - unexpected horizontal line repaint issue in pull-down menulist
You need to log in before you can comment on or make changes to this bug.