Add-on oldbar 1.2 Disables on Firefox Start-up

RESOLVED DUPLICATE of bug 547708

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 547708
9 years ago
9 years ago

People

(Reporter: Kathy, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

When I restart my pc and open Firefox, the add-on oldbar 1.2 is disabled and it says a compatible version is not available.  I click on check for updates, it updates and I restart firefox and then it works perfectly.  This only happens when I restart the pc, not when I exit and restart firefox.

Reproducible: Always

Steps to Reproduce:
1.turn on pc
2.open firefox
3.tools, add-ons
4.click find updates
5.restart firefox
6.oldbar add on works


Expected Results:  
The add on should be enabled each time fire fox starts when the pc is first turned on.

The same update to firefox has also caused the Norton Tool bar to re-appear each time as well.  I disable the add on and yet on a pc restart, there it is again.  I commented on this under a different bug filed by another user.

p.s.  I hate the new URL bar
So, you update it, it says it works, then you restart again, and it says it doesn't?
(Reporter)

Comment 2

9 years ago
Almost.  It actually does work.  I can exit firefox on and off all day and it continues to work.  It stops working when I shut down the pc.  When I restart the pc and then firefox, it is back to its non working condition again.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100301 Namoroka/3.6.2pre

I tested this but was not able to reproduce.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → 1.9.2 Branch
(Reporter)

Comment 4

9 years ago
What other information can I provide?  Screen shots, system info, etc.?

This all started with the last and prior firefox update.  

The same issue exists with the Norton tool bar. 

Something is up with how firefox deals with add-on but only on the initial firefox launch after system start up.  This never happened before with any firefox update or add on.
Firefox doesn't do anything different when started up the first time after your computer boots than it does under any other startup so I'd be inclined to suspect something specific to your computer.

Can you attach copies of extensions.log, extensions.cache, extensions.rdf and extensions.ini from your profile folder immediately after starting your computer (before starting Firefox) and then after starting and quitting Firefox.

http://support.mozilla.com/en-US/kb/Profiles
(Reporter)

Comment 6

9 years ago
Created attachment 429875 [details]
screen shots of firefox problem

Screen shots showing the problem.
(Reporter)

Comment 7

9 years ago
(In reply to comment #5)
> Firefox doesn't do anything different when started up the first time after your
> computer boots than it does under any other startup so I'd be inclined to
> suspect something specific to your computer.
> 
> Can you attach copies of extensions.log, extensions.cache, extensions.rdf and
> extensions.ini from your profile folder immediately after starting your
> computer (before starting Firefox) and then after starting and quitting
> Firefox.
> 
> http://support.mozilla.com/en-US/kb/Profiles

Do you want print outs or the actual files?
(In reply to comment #7)
> (In reply to comment #5)
> > Firefox doesn't do anything different when started up the first time after your
> > computer boots than it does under any other startup so I'd be inclined to
> > suspect something specific to your computer.
> > 
> > Can you attach copies of extensions.log, extensions.cache, extensions.rdf and
> > extensions.ini from your profile folder immediately after starting your
> > computer (before starting Firefox) and then after starting and quitting
> > Firefox.
> > 
> > http://support.mozilla.com/en-US/kb/Profiles
> 
> Do you want print outs or the actual files?

The actual files.
(Reporter)

Comment 9

9 years ago
Created attachment 429883 [details]
Extension files as requested

there are four sets of files 
1.  Right after pc start up before I opened firefox.  no other programs opened
2.  Right after I first started firefox with firefox open
3.  after disabling norton tool bar and updating oldbar addon and restarting firefox
4.  after exiting firefox, no programs opened

please note only two of the files you requested were available at system start up.
(Reporter)

Comment 10

9 years ago
this may be associated with bug 547772 that involves the norton tool bar not staying disabled after a system restart.  That is in my screen shots.
Attachment #429875 - Attachment mime type: application/x-itunes-itlp → application/msword
Attachment #429883 - Attachment mime type: application/x-itunes-itlp → application/zip
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547708
You need to log in before you can comment on or make changes to this bug.