Auto switch to already open folder tab

RESOLVED DUPLICATE of bug 511362

Status

Thunderbird
Toolbars and Tabs
--
enhancement
RESOLVED DUPLICATE of bug 511362
9 years ago
7 years ago

People

(Reporter: Dave Trollope, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3

When clicking on a folder that is already open in a tab, the current tab changes to that folder. It would be more useful if the existing open tab was switched to instead of having two tabs with the same folder.

Say you are looking at your inbox and you open folder Sent in a new tab. Now you click on your inbox in the folder list (not the tab). inbox is loaded in to the current tab. Would be nice if it just switched tabs.




Reproducible: Always

Steps to Reproduce:
1. Open Inbox in tab
2. Open Sent in tab
3. Click on Inbox in folder list
Actual Results:  
two tabs now exist with Inbox

Expected Results:  
Sent is left in the tab and the current tab is now the Inbox tab

A related bug is bug 522751 but this suggestion has a much narrower scope. Just switch to already open tabs instead of loading.

Updated

8 years ago
Severity: normal → minor
Summary: Auto switch to open tab → Auto switch to already open folder tab

Updated

7 years ago
Severity: minor → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511362
You need to log in before you can comment on or make changes to this bug.