Location bar's tooltips broken (don't appear)

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
8 years ago
2 years ago

People

(Reporter: u88484, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
The location bar's tooltips are broken.

If you start the browser in small or large icons mode then no tooltip appears.

If you start the browser in large icon mode then tooltips don't appear; switch to small icons mode and a blank tooltip appears.

If you start the browser in small icons mode then tooltips don't appear; switch to large icons mode then tooltips work correctly.

Works in Firefox 3.6 so I'll attempt to narrow down a regression range.
(Reporter)

Comment 1

8 years ago
Works:
86a6b2485640 01-24-2010

Broken:
d8177ec0014c 01-25-2010

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86a6b2485640&tochange=d8177ec0014c

99.9% sure this was caused by Bug 480443 especially since this looks like what Gavin was talking about in bug 480443 comment 6.
Blocks: 480443
(Reporter)

Comment 2

8 years ago
Just wanted to clarify that I now know that the tooltips shouldn't always show but there is still at least one bug here because when switching between small and large icons and vice verse, the aforementioned things in comment 0 happen.
works for me
Component: XUL → Location Bar
Product: Core → Firefox
QA Contact: xptoolkit.widgets → location.bar
(Reporter)

Comment 4

8 years ago
Created attachment 430066 [details]
Screenshot

Screenshot showing a tooltip for a bugzilla page which has no where close to a long enough URL to cause an overflow and therefore a tooltip.

The screenshot also shows the blank tooltip which I incorrectly described earlier, same steps still apply but the location bar has to have "Search Bookmarks and History" in it for the blank one to appear.  If a page URL is in the location bar then the tooltip appears with the page's address in it.
(Reporter)

Comment 5

8 years ago
Also make sure that the location bar does _not_ have focus when you try to reproduce.
Does it do the same thing if you use the default theme?
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> Does it do the same thing if you use the default theme?

Yep, same thing.  FWIW that was just a persona but I did try without it loaded.
I suspect from your screenshot you have the StrataBuddy extension (or something similar) installed. If you do, that is the cause.

I've just had a look at their code, and they're overriding the location bar with their own, which is copied and modified from Mozilla code from 2007. Needs updating.
(Reporter)

Comment 9

8 years ago
No extensions are enabled.  Minefield looked the way it did in the screenshot because of the Minefield persona and because of recent Theme patches that Dao has landed.

I can reproduce this on a new profile but only after enabling direct2d and direct write.  Sorry, I didn't know that could have been a trigger for this bug.

Enable 'gfx.font_rendering.directwrite.enabled'.  Modify the value of 'mozilla.widget.render-mode' to 6
(Reporter)

Comment 10

8 years ago
Bas, CCing you here since it seems that direct2d/direct write trigger this bug.

Only 'gfx.font_rendering.directwrite.enabled' needs to be enabled for this bug to show.
Depends on: 550366
The overflow event occurs even when the text is not overflowing, in at least two instances - when the urlbar is added back to the DOM after the customize toolbar dialog, and when the value goes from "" to anything.

Looks like whatever measures the text size in DirectWrite is producing bad results.
No longer depends on: 550366
Depends on: 588604

Comment 12

6 years ago
Does this still exist in Firefox 6 or later?
(Reporter)

Comment 13

6 years ago
Still no tooltips but I can't reproduce the instance with the blank tooltip showing anymore.
there's no more small/large icons mode, if this still happens, it needs better STR.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.