redrawing problem with select/listbox

VERIFIED DUPLICATE of bug 95703

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 95703
18 years ago
17 years ago

People

(Reporter: Michael Marxmeier, Assigned: waqar)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bad user experience, URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test3 i686; m18) Gecko/20001002
BuildID:    2000100208

When scrolling forward (such that the listboxes at the top of
the query page are no longer visible) and then backwards again
the listbox has a redraw problem. Depending on scroll speed
a number of white lines is drawn (the slower the scrolling
is performed the more).						

Reproducible: Always
Steps to Reproduce:
Go to URL http://bugzilla.mozilla.org/query.cgi
scroll forward so the listboxes at the top of
the page are no longer visible and then backward
again (slowly for best effect).

Results:  White lines drawn in the listboxes					

Seems specific to select/listbox.

Comment 1

18 years ago
reassigning
Assignee: rods → waqar

Comment 2

18 years ago
Michael, is this still being seen (this bug hasn't been updated in over a month)?
(Reporter)

Comment 3

18 years ago
Yes. Just checked it with build 2000110208 on Linux.

Comment 4

18 years ago
Marking as NEW as per reporter comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Updated

18 years ago
Target Milestone: --- → Future

Comment 6

18 years ago
Created attachment 32142 [details]
Screenshot of the listbox with the wrong redrawn listbox

Comment 7

18 years ago
I think it's more serious than minor bug. It's really unpleasant and
unprofessionaly looking. And if it paints some chaotic text into the listbox
someone can be easily fooled that it is correct choice in the listbox.

Comment 8

17 years ago
I'm seeing this on Win98 build 2001060804 (same effect, same box).

Comment 9

17 years ago
Raising severity. Os->all.
Severity: minor → normal
OS: Linux → All
Whiteboard: bad user experience

Comment 10

17 years ago
Can't reproduce on 2001062508 on Linux/X11 - at least not with the instructions
posted to the bug. Are white lines supposed to come up and appear in the middle
of the listbox? Can somebody post a screenshot of the problem?

Otherwise, if nobody can confirm, please mark WORKSFORME

Comment 11

17 years ago
No it's definitely not WFM. It's still there. 
How to reproduce?
When you have opened this page, try scrolling it up/down to just uncover/cover
the select listbox of cced people. You should see the artifacts immediately.
If you don't see them you just have to change the amount of the scrolling.
(Reporter)

Comment 12

17 years ago
Testing with build 2001062212 i can no longer reproduce the 
artifacts on the query.cgi page. However as described by 
Thomas Mraz i can reproduce them on the bug page itself.
I'll attach a small screen dump to visualize the problem.
(Reporter)

Comment 13

17 years ago
Created attachment 40060 [details]
screenshot

Comment 14

17 years ago
Try grabbing the slider, and scroll backwards this page very slowly.

It doesn't draw lines, but gets part of the displayed page as pictures inside
the listbox. It seems to get the image from the left side of the currently
displayed page, but not exactly:
The attached image shows the two valid items in the list (the email addresses),
 the bottom of the [Commit] [Reset] buttons from below this text entry box,
which I am typing into, and parts of the [Back] and [Bookmarks] buttons, BUT it
also has a grey (my default background color) area, which is NOT found on any of
my open windows.


Mozilla 0.9.2 Build ID: 2001062823, XFree86 4.0.3

Comment 15

17 years ago
Created attachment 40897 [details]
Screenshot of a corrupted listbox

Comment 16

17 years ago
Forget what I said. This is reproducible on 2001082708, and even though with my
fixes to bug 96534 I can't seem to reproduce this just by selecting query.cgi
Programs:, I definitely can see this while scrolling slowly.

And alas, it's true: slow-scrolling does make incorrect text show up inside the
textbox. And, interestingly enough, the text that shows up in the Version and
Component area is the same text as shown in the Program: area! I'm attaching a
screenshot so it can be seen.

Comment 17

17 years ago
Created attachment 47311 [details]
screenshot - gal-python and infogratis belong only in the Program box, but they show up in version and component!

Comment 18

17 years ago
Dupe of bug 95703 (or vice versa).

Comment 19

17 years ago
I'll mark this as dupe of bug 95703 because that one recieved more recent
attention... If you disagree feel free to resolve otherwise


*** This bug has been marked as a duplicate of 95703 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
VERIFIED based on comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.