opening local file results in graphic defects in new window

VERIFIED DUPLICATE of bug 5490

Status

Core Graveyard
Tracking
P2
normal
VERIFIED DUPLICATE of bug 5490
19 years ago
a year ago

People

(Reporter: cpratt, Assigned: David Hyatt)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
build id: 1999042608
reproduces on: mac os 8.5.1, windows nt
linux crashes when doing this - see other bug...

to reproduce: select open from the file menu. open a local html file. the window
that comes up exhibits graphic defects: the back/forwards/reload etc. buttons
may or may not draw. if there is a graphic image at the top of the page it may
draw over the location: url or on the background for that part of the page, etc.

expected result: the newly created window that displays the local file should
look as good as the main apprunner window (that is, no graphic defects, etc.)

Updated

19 years ago
Assignee: don → law
Priority: P3 → P2
Target Milestone: M5

Comment 1

19 years ago
Assigned to law.

Bill, is this fixable for M5?

Comment 2

19 years ago
This is yet another manifestation of the "shared XUL document" problem.  I'm not
sure how we're going to fix it.  It's an xptoolkit problem (vs. an xpapps
problem).  I'll try to find out who to assign it to and do so tomorrow.

Updated

19 years ago
Assignee: law → trudelle
Target Milestone: M5

Comment 3

19 years ago
Re-assigned to trudelle.

Peter, Bill says this looks to be caused by the "shared XUL document" problem
that Hyatt and Waterson are working on fixing.

Updated

19 years ago
Assignee: trudelle → hyatt
Target Milestone: M6

Comment 4

19 years ago
reassigning to hyatt as p2 for m6, cc'ing waterson
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
Could you elaborate, Bill?  What's causing the bad drawing?
(Assignee)

Comment 6

19 years ago
*** Bug 5353 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

19 years ago
I don't see how a few shared nodes between the two navigator.xul instances could
cause garbled drawing.  Is this really the cause?
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M5
(Assignee)

Comment 8

19 years ago
Moving back to M5.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

19 years ago
*** This bug has been marked as a duplicate of 5490 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
QA Contact: 3853 → 4137
(Reporter)

Comment 10

19 years ago
Mmmm, conflation is good. Marking verified duplicate.

Comment 11

19 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.