[cairo-qt] Text spacing is bad in Fennec (gfxFT2Fonts.cpp)

RESOLVED DUPLICATE of bug 550468

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 550468
8 years ago
8 years ago

People

(Reporter: romaxa, Assigned: MikeK)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Currently QT fennec is using gfxFT2Fonts.cpp, and text spacing is bad.
I think we have to do fix similar to bug 470440.

Updated

8 years ago
Blocks: 549975

Updated

8 years ago
Assignee: nobody → mkristoffersen
(Assignee)

Comment 1

8 years ago
Created attachment 431080 [details]
Example with hinting turned on and off

In the attachment I have modified the default cairo font options to disable hinting, the result is not convincing, might there be other places where hinting could be used?  - we don't use Pango for Qt builds.
(Reporter)

Comment 2

8 years ago
Pango backend now available for Qt builds... it would be nice to see same test results for Qt build with pango backend enabled.
(Assignee)

Comment 3

8 years ago
In that case, that sounds like the ideal solution, as we have already fixed the issue in the Pango code, should that be a separate bug blocking this one, or should we just say that it is the solution to this bug?  

(In reply to comment #2)
> Pango backend now available for Qt builds... it would be nice to see same test
> results for Qt build with pango backend enabled.

Do we need to integrate a new version of Pango (which one?), or do our current integration support Qt?
(Assignee)

Comment 4

8 years ago
Created attachment 431818 [details]
Now with pango support

After Pango in bug 550469 has been added to trunk, this bug seems to have been fixed as we expected :)
Attachment #431080 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550468
You need to log in before you can comment on or make changes to this bug.