Closed Bug 549953 Opened 13 years ago Closed 13 years ago

[d2d] Resizing large images that create horizontal and/or vertical scrollbars cause image artifacts

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 549097

People

(Reporter: u88484, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot
Resizing large images that create horizontal and/or vertical scrollbars cause image artifacts.

STR: (depending on scroll resolution, resize browser window to be smaller)
1) Load https://bug549269.bugzilla.mozilla.org/attachment.cgi?id=429472
2) Click the image to resize it
3) Notice on the very left size and sometimes the top that about 10 pixels of the image is left over from before the image was resized.

See screenshot.  left side of image is after the resize and the right side of the image is after the resize and scrolled to the left to show that it is only a few pixels left over from the original sized image.
I believe this is related to bug 549097. It appears a similar effect:

Take a big image like:

http://apod.nasa.gov/apod/image/0304/bluemarble2k_big.jpg

1. Size it up
2. Scroll down about a bit
3. Size it down
4. Size it up

We can now see at the top a row of the pixels that would have been there if we scrolled down the window when the downsized image was there. It seems we're not drawing the image to the full area where it needs to be, here two, I don't have a good explanation yet.
This is indeed a duplicate of 549097. There's a patch there.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549097
You need to log in before you can comment on or make changes to this bug.