If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Undo/redo is broken at the moment

RESOLVED FIXED in 0.6.2

Status

Skywriter
Key Bindings
P1
blocker
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Julian Viereck, Assigned: Julian Viereck)

Tracking

unspecified
0.6.2
Other
Other

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Typing CMD+Z or CMD+SHIFT+Z don't undo or redo changes made in the editor.
(Assignee)

Comment 1

8 years ago
I'm working on this right now. 

The problem is based on two things:
1) There is a requirement in the supported/AppSupport/plugin.json file, that is 
never true
2) On Firefox, the undo/redo keys are sometimes handled twice. I've fixed that 
in my local repo but I want to have that code sit in SC and not to be a hack in 
the bespin code base, which requires a little bit more work to be done. Also, I 
have to make sure that things work fine on Windows as well...
Assignee: nobody → julian.viereck
(Assignee)

Comment 2

8 years ago
Created attachment 430632 [details] [diff] [review]
Fix this bug.

See the comments in the patch.
(Assignee)

Updated

8 years ago
Attachment #430632 - Attachment is patch: true
Attachment #430632 - Attachment mime type: application/octet-stream → text/plain
Attachment #430632 - Flags: review?(pwalton)
(Assignee)

Updated

8 years ago
Severity: normal → blocker
Priority: -- → P1

Updated

8 years ago
Target Milestone: --- → 0.6.2
Merged, thanks!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Attachment #430632 - Flags: review?(pwalton) → review+
You need to log in before you can comment on or make changes to this bug.