audio element is buffered on page load, though autobuffer is not set

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: lsd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I've posted several HTML5 audio elements to my blog without incident, but with one specific file, the entire Ogg file is buffered at page load. I've isolated this in to a test page which demonstrates the issue. 

It may actually be an issue with the file itself, but I haven't noticed any other issues with it, and the playback does work fine. Even if it is a file issue (ie: Firefox was unable to determine the file's length without downloading it all), Firefox should still avoid doing excessive buffering.

Reproducible: Always

Steps to Reproduce:
1. Open the linked test page
2. Watch as the audio element downloads the entire audio file before it finishes its initial buffering



Expected Results:  
The audio element should only buffer the very start of the file and then stop, until the play button is hit
I can't reproduce this.  Is it possible that your connection is fast enough that a large chunk (or the entire file) is downloaded before Firefox has a chance to suspend the download?  Or perhaps the file is already cached on your machine?
(Reporter)

Comment 2

9 years ago
You're right -- it looks like this wasn't a Firefox issue at all, but a problem with the transparent proxy at my office. I set up Firefox to use an external proxy that I control (a standard Squid install), re-tested, and it behaved as expected.

Sorry for the mix-up!
Thanks for the update!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.