Cannot quicksearch for multiple bug ids by separating them with a comma

RESOLVED FIXED in Bugzilla 3.6

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: wu-d, Assigned: mkanat)

Tracking

({regression})

3.5.3
Bugzilla 3.6
regression
Bug Flags:
approval +
approval3.6 +
blocking3.6 +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 

Cannot search bugs by Quicksearch by Bug number.

I input: 380,356 on quecksearch, I got an error message shown below:

URL: http://xxxxx/cgi-bin/bugzilla/buglist.cgi?quicksearch=380%2C356

Cannot seem to handle bug_id and include together.


Reproducible: Always

Steps to Reproduce:
1. Input 380,356 on quecksearch.
2. push Search button.
3.
Actual Results:  
An error message shown below:

URL: http://xxxxx/cgi-bin/bugzilla/buglist.cgi?quicksearch=380%2C356

Cannot seem to handle bug_id and include together.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5.3

Comment 1

9 years ago
This was working fine in Bugzilla 3.2 and 3.4, and is indeed broken in 3.6 and 3.7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.6
(Assignee)

Comment 2

9 years ago
It may be intentionally broken, but it may not be.
(Assignee)

Updated

9 years ago
Summary: Cannot search bugs by Quicksearch by Bug number. → Cannot quicksearch for multiple bug ids by separating them with a comma
(Assignee)

Comment 3

9 years ago
  Turns out this was a tiny oversight from bug 537746. I have a patch ready, will attach it now.
Depends on: 537746
(Assignee)

Comment 4

9 years ago
Created attachment 430746 [details] [diff] [review]
v1

  One-line patch.
Assignee: query-and-buglist → mkanat
Status: NEW → ASSIGNED
Attachment #430746 - Flags: review?(LpSolit)
(Reporter)

Comment 5

9 years ago
Thank you, it works.
(Assignee)

Updated

9 years ago
Flags: blocking3.6+

Comment 6

9 years ago
Comment on attachment 430746 [details] [diff] [review]
v1

r=LpSolit
Attachment #430746 - Flags: review?(LpSolit) → review+

Updated

9 years ago
Flags: approval3.6+
Flags: approval+
(Assignee)

Comment 7

9 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified Bugzilla/Search/Quicksearch.pm
Committed revision 7085.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/                         
modified Bugzilla/Search/Quicksearch.pm
Committed revision 7047.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.