If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attached files "missing" or not seen, seeing winmail.dat attachment instead

RESOLVED DUPLICATE of bug 77811

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 77811
8 years ago
5 years ago

People

(Reporter: Guirauton, Unassigned)

Tracking

({testcase})

x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

Opening a message I see on the (bad located) bottom line an attached file winmail.dat  In fact using a webmail browser (GMail) to open the same mail the attached file is CHEQUE~1.PDF. ! ! !  
Remark : the attached file is only 1071Ko.



Reproducible: Didn't try

Actual Results:  
The winmail.dat opened does not match with the original attached file.


about:buildconfig

Source

Built from http://hg.mozilla.org/releases/mozilla-1.9.2/rev/448d0d2d310c
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --enable-tests
(Reporter)

Comment 1

8 years ago
May I continue using Thunderbird ?
The localisation of the attached file line is not good (better when ou send a mail and attache a file - on the top right)
AND
some attached files are not mentionned !!

Thanks to your answer I use Thunderbird as professional and would not go back to Microsoft ...
So you sent an email with multiple attachments but they did not all come through correctly? Is that correct?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> So you sent an email with multiple attachments but they did not all come
> through correctly? Is that correct?

No, the mail was received and the attachement was wrong in terms of name AND content.  The same e-mail read with another tool (outlook and GMail) is correct and the attached file is OK.
So the email is correct but the attachment is not?

Is the attachment from a different email?

Is the attachment completely unrecognizable to you?
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> So the email is correct but the attachment is not?
> 
> Is the attachment from a different email?
> 
> Is the attachment completely unrecognizable to you?

Hello You can see in the three attached file what is shown opening the same mail with Thunderbirs, outlook or Gmail.
Version: unspecified → 3.0
(Reporter)

Comment 6

8 years ago
Created attachment 430549 [details]
Outlook view of a file coming from Ameli.fr
(Reporter)

Comment 7

8 years ago
Created attachment 430550 [details]
GMail view of a file coming from Ameli.fr
(Reporter)

Comment 8

8 years ago
Created attachment 430552 [details]
Thunderbird view of a file coming from Ameli.fr
Not enough information for me to reproduce the issue. To debug the issue, we need to be able to reproduce it consistently. Try the standard diagnostic and safe mode. If it still messes up, give steps to reproduce. Include any files that are necessary to reproduce. See these links.

http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird
http://kb.mozillazine.org/Safe_Mode
https://developer.mozilla.org/en/Bug_writing_guidelines





Possibly related bugs. 

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=+182627+82016+226681+532900+88542+538407+538407+142517+203700+229872+315353
Gui could you do something for us ? Save that email using File -> save. Open it with notepad remove your name and change the html links in it save it. and attach it here so we can try to see what's wrong in the email.
(Reporter)

Comment 11

8 years ago
Created attachment 433200 [details]
Modified mail (after export)

Bag attachement to the Mail received
(Reporter)

Comment 12

8 years ago
Created attachment 433202 [details]
winmail.dat file as attached (name not OK and content i dont know)

Attached file to the mail in Thunderbird
Keywords: testcase
Matt, Guirauton, can you reproduce this on current version ??

Updated

5 years ago
Attachment #433202 - Attachment description: File as attached (name not OK and content i dont know) → winmail.dat file as attached (name not OK and content i dont know)

Comment 14

5 years ago
wfm TB12.0.1/WinXP

Testcase of attachment 433202 [details] is perfectly fine, a message with attached winmail.dat. The winmail.dat can be saved and decoded, correctly contains "cheque_pe.pdf."

So the only "problem" here is:
- tell your friends to stop sending attachments with outlook's proprietary winmail.dat / TNEF format (or better, to just use TB).
- TB does not have native support for proprietary format of winmail.dat, which is a non-standard format used by M$. That's Bug 77811.
Meanwhile, there's an "Lookout" addon for TB which can read these alien files:
https://addons.mozilla.org/thunderbird/addon/lookout/

Gmail has an inbuilt converter that extracts contained files from winmail.dat, so users don't see any trace of real winmail.dat attachment (just tested - good to know ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Summary: Attached files missing or not seen → Attached files "missing" or not seen, seeing winmail.dat attachment instead
Duplicate of bug: 77811
You need to log in before you can comment on or make changes to this bug.