414 Request-URI Too Long: Buffer overflow detected

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: jsoya, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.4; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; eSobiSubscriber 2.0.4.16; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 

This happens when FF runs on WIN7, bur not on Vista

Reproducible: Always

Steps to Reproduce:
1. Just do it in WIN7 and it fails
2. Do it on Vista and it works
IE have no problems
Actual Results:  
414 Request-URI Too Long: Buffer overflow detected 

Expected Results:  
Normal response - with updated screen

The WEB server is an Embedded processor and is therefore more critical with the returned size rom INPUT/GET. 

If you need it i can device a special userid/password for your testing
Component: Build Config → Networking: HTTP
Product: Firefox → Core
QA Contact: build.config → networking.http

Comment 1

9 years ago
Not security-sensitive. Please provide an HTTP log, which will show the URLs that Firefox is actually requesting: https://developer.mozilla.org/en/HTTP_Logging
Group: core-security
(Reporter)

Comment 2

9 years ago
Created attachment 430619 [details]
This a trace from VISTA that runs ok
(Reporter)

Comment 3

9 years ago
Created attachment 430621 [details]
This a log from WIN7 that gives overflow

Comment 4

9 years ago
Win7/failing:

0[826140]: http request [
0[826140]:   GET /config/config.htm?description=DEVELOPMENT HTTP/1.1
0[826140]:   Host: fiasko3024.selfip.com
0[826140]:   User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; da; rv:1.9.2) Gecko/20100115 Firefox/3.6
0[826140]:   Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
0[826140]:   Accept-Language: da,en-us;q=0.7,en;q=0.3
0[826140]:   Accept-Encoding: gzip,deflate
0[826140]:   Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
0[826140]:   Keep-Alive: 115
0[826140]:   Connection: keep-alive
0[826140]:   Referer: http://fiasko3024.selfip.com/config/config.htm
0[826140]:   Cookie: dhtmlgoodies_tab_menu_tabIndex=index%3A%201; dhtmlgoodies_tab_menu_tabIndex=index%3A%201
0[826140]:   Authorization: Basic ********************
0[826140]: ]

Vista/ok:

0[82d140]: http request [
0[82d140]:   GET /config/config.htm?description=DEVELOPMENT HTTP/1.1
0[82d140]:   Host: fiasko3024.selfip.com
0[82d140]:   User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; da; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
0[82d140]:   Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
0[82d140]:   Accept-Language: da,en-us;q=0.7,en;q=0.3
0[82d140]:   Accept-Encoding: gzip,deflate
0[82d140]:   Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
0[82d140]:   Keep-Alive: 115
0[82d140]:   Connection: keep-alive
0[82d140]:   Referer: http://fiasko3024.selfip.com/config/config.htm
0[82d140]:   Cookie: dhtmlgoodies_tab_menu_tabIndex=index%3A%201
0[82d140]:   Authorization: Basic ********************
0[82d140]: ]

The request looks mostly-identical: there is a slight difference in the User-Agent, but the working UA is actually the longer one. The Win7 version has two cookies, which is slightly odd. Could you try clearing cookies on win7 and trying again?
(Reporter)

Comment 5

9 years ago
With Cookies cleared on WIN7 it worked.

Comment 6

9 years ago
This is a bug/limitation of the server in question, I think. Glad we could help, though!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

9 years ago
Thanks for your help. 
Cookie usage has been removed from the javascript.
You need to log in before you can comment on or make changes to this bug.