Closed Bug 550635 Opened 11 years ago Closed 10 years ago

Connection status should appear in the right of the location bar rather than the status bar

Categories

(Firefox :: Address Bar, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: domthedude001, Unassigned)

References

Details

(Keywords: uiwanted)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Firefox 3.7a3pre

The connection status (eg: "Waiting for mozilla.org") should appear in the right of the location bar rather than the status bar.

Reproducible: Always

Steps to Reproduce:
1. Connect to a page.
Actual Results:  
The connection status is visible in the status bar.

Expected Results:  
The connection status is visible in the location bar (on the right-hand side).

This functionality is already available in Fission - if anyone wants to borrow some code.
AMO: https://addons.mozilla.org/en-US/firefox/addon/1951
Homepage: http://mozilla.zeniko.ch/fission.html

"Done" should have the option of either not appearing, or being turned into the page title (since the titlebar has also been proposed to be removed, it will allow people to be on a page, know the title, and not have a titlebar).
Component: Layout → Location Bar
Product: Core → Firefox
QA Contact: layout → location.bar
See Also: → 550631
Keywords: uiwanted
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.