Editor "blinks" when jumping back from the commandline

RESOLVED FIXED

Status

Skywriter
Editor
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Julian Viereck, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
If you focus the commandline in Bespin and then focus the editor again, you 
will notice that the editor "blinks" for a short time (blinking = you see the 
blue background color of SproutCore).
(Reporter)

Comment 1

8 years ago
Created attachment 430847 [details] [diff] [review]
Fix the bug.

The blinking is caused by the fact, that jumping back to the editor resizes the editor's canvas. If you resize a HTML5 canvas, the entire content is dropped. Due to this, the editor is back again AFTER the first repainting, which takes at least 33ms. In the meantime, you see the background of the SproutCore app.

To fix this, I've prevented the canvas from downsizing.
Attachment #430847 - Flags: review?(pwalton)
(Reporter)

Updated

8 years ago
Whiteboard: needs-pull
Having the canvas unable to shrink is annoying, but I don't see any way around it short of having multiple canvases (which is something we probably want to do at some point). For now this patch is fine. Applied as changeset 158cbe613fd1.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: needs-pull
Duplicate of this bug: 549998
Attachment #430847 - Flags: review?(pwalton) → review+
You need to log in before you can comment on or make changes to this bug.