Changes in "Hardware" and "OS" label is not reflecting on the "Edit Bug" screen

RESOLVED DUPLICATE of bug 451804

Status

()

Bugzilla
User Interface
RESOLVED DUPLICATE of bug 451804
9 years ago
9 years ago

People

(Reporter: Shailesh, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Build Identifier: Bugzilla 3.4.4

I wanted to change the label for default field i.e. Platform and OS to "Tested On Platform" and "Operating System Used" respectively in Bugzilla. I changed the label at following templates files and change is reflected while logging new bug and searching of the bugs but not available while editing existing bugs.
       Templates which I modified are as below: 
          - /Bugzilla/Field.pm (View CVS log or CVS annotations)
          - /template/en/default/pages/fields.html.tmpl
          - /template/en/default/pages/quicksearchhack.html.tmpl
          - /template/en/default/pages/release-notes.html.tmpl
          - /template/en/default/list/edit-multiple.html.tmpl
          - /template/en/default/global/field-descs.none.tmpl
          - /template/en/default/whine/mail.txt.tmpl
          - /template/en/default/bug/create/create.html.tmpl
          - /template/en/default/bug/create/create-guided.html.tmpl
          - /template/en/default/admin/params/bugfields.html.tmpl
          - /template/en/default/search/form.html.tmpl 
Please let me know if any other templates which needs to be updated.



Reproducible: Always

Steps to Reproduce:
1. Update all the Bugzilla template files (replace "Platform" with "Tested On Platform" as explained in Details section
2. Login Bugzilla and edit any existing bug

Actual Results:  
Two default fields i.e. Platform and OS should be dsiplayed as  "Tested On Platform" and "Operating System Used" respectively in Bugzilla.

Expected Results:  
Fileds are displayed as Platform and OS evn after changing template files in Bugzilla.

Comment 1

9 years ago
All templates should use field_descs.rep_platform instead of being hardcoded in templates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Hardware: x86 → All
Resolution: --- → DUPLICATE
Version: unspecified → 3.4.4
Duplicate of bug: 451804

Comment 2

9 years ago
@Shailesh  you missed /template/en/default/bug/edit.html.tmpl which is DEFINATELY the one you need to get. This is still a dup of the platform bug but that should help you a bit.

Also make sure to run ./checksetup
(Reporter)

Comment 3

9 years ago
Thanks. it worked for me.
(Reporter)

Comment 4

9 years ago
One small question here. I am still getting bug e-mail notification with old label as "Platform" in place of new label "Tested On Platform".

Please suggest me: which template file needs to be updated for this?
You need to log in before you can comment on or make changes to this bug.