HTTPS connections to bugzilla.org or www.bugzilla.org fail (no connection or wrong certificate)

RESOLVED WONTFIX

Status

()

Bugzilla
bugzilla.org
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Nico R., Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100215 Gentoo Firefox/3.6

bugzilla.org and www.bugzilla.org behave differently when accessed via HTTP and when accessed via HTTPS.

Reproducible: Always

Steps to Reproduce:
A. Open https://bugzilla.org/ in your web browser.

B. Open https://www.bugzilla.org/ in your web browser.
Actual Results:  
A. Connection fails.

B. Your web browser receives a certificate for *.mozilla.org.

Expected Results:  
A.1. Web browser receives a certificate which is valid for
  a) either bugzilla.org and www.bugzilla.org, or
  b) only bugzilla.org, or
  c) bugzilla.org and one or more other hosts.
  2. Web browser is redirected to https://www.bugzilla.org/ .
     Rationale: http://bugzilla.org/ redirects to http://www.bugzilla.org/ .

B.1. Web browser receives a certificate which is valid for
  a) either only www.bugzilla.org, or
  b) bugzilla.org and one or more other hosts.
  2. Web browser is served the same content as for http://www.bugzilla.org/ , but over HTTPS.
     Or course, referenced images, etc. also use HTTPS (or relative) URIs so that the user does not get “mixed content”.
     (Additional suggestion: links to other pages on www.bugzilla.org or to other pages operated by the Mozilla Foundation or Mozilla Corporation also use the HTTPS protocol.)
We don't offer support for https on bugzilla.org at all.  It works by accident without the www because it happens to run on the same box with another host that does offer https (and that's the site the certificate is for).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.