Closed Bug 550756 Opened 11 years ago Closed 10 years ago

Direct 2d all Content is transparent

Categories

(Core :: Graphics, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Dpeelen, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [dupeme])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a3pre) Gecko/20100305 Minefield/3.7a3pre (.NET CLR 3.5.30729)

When i set mozilla.widget.render-mode;6 and gfx.font_rendering.directwrite.enabled;true each time i load a new page, use the back/forward button, click a link, enter a url in the adress bar and open it then the entire content shows transparent.

Sometimes there are also weird graphical artifacts, like, the page does display for .5 sec, or i get a grey background instead of a transparent one.

When i resize firefox, or switch tab, or switch windows and back again, the tab does dislpay normal.
While tab switching, i also see bug 532106 for a split second.

My hardware/software: Win vista, Intell Core2 Duo E6750 @2.66GHz, ATI Radeon HD 4870.

I've also heard another person with this same problem, he could get it solved by switching to the Windows Classic theme. Didn't try that myself yet.

Reproducible: Always
Blocks: 527707
Dorus, isn't this bug a duplicate of bug 532106?  That bug covers switching tabs, loading tabs and other times that this happens.
Whiteboard: [dupeme]
No, i first thought so too, but switching tab i one of the use cases that actually brings this back to normal.

Of course it's very well possible these 2 bugs have the same root problem, but i can't read the code for that :)
Same root cause seems plausible, but since we've yet to find a cause for either. Any such speculation will have to wait I suppose.
I am seeing exactly this too, and currently it prevents me from turning on GPU rendering at all times, since it makes it impossible to surf normally (always having to switch to another tab and then back, to see the content etc).
Have you tried with a fresh profile and no extensions, maybe use safe mode to test?
Fresh profile: yes
Safe mode: yes

Both still gives this problem using the latest nightly (20100621).
Are you on the latest ATI drivers?
Yes, just updated them, still the same problem.
Really weird, my own 4870 with the latest drivers works fine. I wonder if this is somehow a Vista thing but I don't see how it could be.
True, i can confirm this bug is not seen on my laptop (win 7 64 bit with mobility radeon HD 4570).

Let's see if i can get my hands on another vista system and confirm there.
I am still seeing this, and shipping a release with it is something we might regret. I have Windows Vista with a Nvidia card, both with all the latest updates/drivers installed. Hardware acceleration is working great otherwise, so I really hope that this can be resolved before the final release.
This might be a breakthrough. Previously, I haven't used the hardware accelerated IE9 Developer Preview on this computer, but I just did. I see this issue there too. This, at least, seems to prove that the problem lies in components we can't do anything about.

Since this issue was seen with an ATI-card as well as my Nvidia (NVIDIA Quadro FX 570M), perhaps it is something problematic about the Vista version of the hardware acceleration software/driver?
Blocks: 3d-driver
No longer blocks: 527707
A better late then never update:
2 weeks ago i got my hands on a vista laptop, there i was unable to reproduce this problem (laptop has no video card AFAIK.

On my desktop (specs mentioned in OP) this problem is still seen on the latest nightly. I'm guessing direct 2d is now on by default since i didn't have to activate it to get this.

Mozilla/5.0 (Windows NT 6.0; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre
Is this still an Issue, Dorus?
Nope, been using FF4 for some times now, no problems so far. Must have been solved.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.