Incompatibility with Thunderbird 3.0.3

RESOLVED WONTFIX

Status

--
critical
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: mstuff, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100216 Fedora/3.5.8-1.fc11 Firefox/3.5.8
Build Identifier: GData Provider 0.6b2pre &  0.7pre & 0.8pre; Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100301 Fedora/3.0.3-1.fc11 Lightning/1.0b2pre Thunderbird/3.0.3

GData Provider will not run on up to date Fedora 11 system

Reproducible: Always

Steps to Reproduce:
1. Run Fedora 11
2. yum update
3. GData Provider stops working
Actual Results:  
GData Provider fails "because it is not compatible with Thunderbird 3.0.3"

Expected Results:  
Installs & runs
For Thunderbird 3.0.* use the Provider for Google Calendar package found here: <https://addons.mozilla.org/thunderbird/addon/4631>.

Nightly test builds are only available for recent Thunderbird 3.1 and 3.2 development builds.
We won't be providing nightly builds for 3.0, due to lack of developer resources. I'm sorry about this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

9 years ago
No worries - but, I'm a little confused.

Is this then a Fedora bug for rolling a T'bird/Lightning combo without support where it's obviously needed (ie, GData)?  Or for rolling T'bird/Lightning combo for the cutting edge of something that's no longer in development...  Or for not getting up to speed with 3.1 & 3.2?

Seems it must be one of the above and I should open a bug on bugzilla.redhat.com?

Many thanks.
(Reporter)

Comment 4

9 years ago
Err, this is strange...

I just followed Stefan's link in Comment 1, just to close off all options before I make another bug report - I've been using the nightlys for some time, but to my surprise 0.6b1 installed without complaint...

But, then I opened my calendar and nothing happens, the properties are all dimmed with the message that the provider for the calendar couldn't be found & I'm unable to create another calendar with google.  Weird I thought...

Weirder still - under add-ons the install of GData Provider says "Requires additional items." and is dimmed...  What "additional items" are needed with GData Provider and Lightning installed on T'bird for them all to function together?

I'm reopening, if there's something obvious I've missed close it down (but please tell me what:)
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
As you can read on the page linked above Provider for Google Calendar 0.6b1 requires Lightning 1.0b1. both releases support Thunderbird 3.0.*.

It seems that you are using old and obsolete nightly builds of Lightning 1.0b2pre. There exist no nightly test builds for Thunderbird 3.0.* anymore, neither Lightning nor Provider for Google Calendar. For Thunderbird 3.0.* use the official released builds.
Closing again per comment 5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

9 years ago
OK, fine - I didn't mean to cause any irritation, I'm just trying to work out what to do.  I'm just installing from the standard Fedora 11 yum repos: "yum update".

If I'm "using old and obsolete nightly builds of Lightning
1.0b2pre", then Fedora is packaging old and obsolete nightly builds of Lightning and that sounds like a bug with Fedora to me?  Comment?

Many thanks.
You need to log in before you can comment on or make changes to this bug.