Images scaled down display a border

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: James Goode, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20110902] [DUPEME], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a3pre) Gecko/20100307 Minefield/3.7a3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a3pre) Gecko/20100307 Minefield/3.7a3pre

Images which are scaled down by Mozilla/Gecko display a 1px black border around the top and left.

Reproducible: Always

Steps to Reproduce:
Go to duckduckgo.com, or create a new web page containing a scaled-down image.
Actual Results:  
Border is displayed around top and left.

Expected Results:  
No border should be seen
This worksforme on Mac...
Keywords: qawanted
(Reporter)

Comment 2

8 years ago
I have tested on Windows, there is no problem.  I think it is Linux-specific.  I forgot to mention, I am using Ubuntu, but the problem occurs even with the latest development release of Firefox/Minefield.
nearest-neighbour sampling problem?

Comment 4

7 years ago
Seems to work for me with a (probaly inappropriately big for a testcasse) JPEG image <img src="http://upload.wikimedia.org/wikipedia/commons/1/16/Kuznetsky_Most_viev.jpg" height="300" /> and

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.3a4pre) Gecko/20100401 Minefield/3.7a4pre
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a1) Gecko/20110901 Firefox/9.0a1

Updated

7 years ago
Whiteboard: [testday-20110902]

Comment 5

6 years ago
Is this bug 468496? If yes, then it should be fixed in Firefox 7. Can you retest?
Whiteboard: [testday-20110902] → [testday-20110902] [DUPEME]

Comment 6

6 years ago
Works for me too, using Firefox 10 on Ubuntu 11.04. Please reopen if you see this problem again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Issue is resolved - clearing old keywords - qa-wanted clean-up
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.