TM: cleanup ->isDenseArray and ->isArray use

RESOLVED DUPLICATE of bug 549010

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 549010
8 years ago
8 years ago

People

(Reporter: gal, Assigned: gal)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
This should be a strict renaming with identical codegen. Touches a bunch of code and needs a solid eyeballing. Waldo to the rescue :)
(Assignee)

Comment 1

8 years ago
Created attachment 431241 [details] [diff] [review]
patch
Assignee: general → gal
(Assignee)

Updated

8 years ago
Attachment #431241 - Flags: review?(jwalden+bmo)
Comment on attachment 431241 [details] [diff] [review]
patch

Since you're here, can you add JSObject::isSlowArray as a sibling to isDenseArray, and call it from inside JSObject::isArray?  This seems like an appropriate time to do it, and I'll want it for a couple patches pretty soon.
Attachment #431241 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549010
You need to log in before you can comment on or make changes to this bug.