Compilation error on toolkit/xre/nsX11ErrorHandler.cpp

RESOLVED FIXED

Status

()

Toolkit
Startup and Profile System
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: James Cook, Assigned: James Cook)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
When compiling the mozilla-central tree against Qt 4.5 there is a compilation error at line 55 of toolkit/xre/nsX11ErrorHandler.cpp.  It appears to be caused by recent changes made in conjunction with bug 549554.  Apologies if this report isn't categorised appropriately.
(Assignee)

Comment 1

8 years ago
Created attachment 431338 [details] [diff] [review]
A patch to rearrange the included headers

As far as I can see this will fix the build error when compiling against Qt 4.5, and doesn't seem to break when compiling against GTK.
Attachment #431338 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #431338 - Flags: review? → review?(dougt)
Duplicate of this bug: 551151

Updated

8 years ago
Attachment #431338 - Flags: review?(dougt) → review+

Updated

8 years ago
Component: Toolbars and Toolbar Customization → Startup and Profile System
QA Contact: toolbars → startup

Updated

8 years ago
Blocks: 549554
(Assignee)

Updated

8 years ago
Keywords: checkin-needed

Updated

8 years ago
Assignee: nobody → bringbackbsd
Pushed in:
http://hg.mozilla.org/mozilla-central/rev/3e66f24faf18
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.