Disable (or pause) sound (audio) output for background tabs

RESOLVED DUPLICATE of bug 449336

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 449336
9 years ago
9 years ago

People

(Reporter: hansschmucker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a3pre) Gecko/20100308 Minefield/3.7a3pre ( LIKE Firefox/3.5 )
Build Identifier: 

When a video or audio element is playing back in a tab that is currently not visible, it continues to output audio. Since no indicators show which tab is playing the sound finding the tab is often almost impossible.

Disabling sound on hidden tabs would solve this. Of course there are cases where you'd want the sound to continue (for example a online radio service), but frankly these cases are relatively rare and do not outweigh the annoyance of having to manually locate and pause a running video/audio.
Users would still be able to keep something running in the background by opening the page in a separate window (dragging the tab to the desktop), which I think would be quite intuitive: Keep it visible to keep it playing.

Pausing any video/audio element would be ideal, but I'm afraid that would interfere to much with the page playing the video/audio, so I'd vote for just silencing it.

Alternatively, the UI could be enhanced to display a marker for a tab playing sound, but I think that would lead to too much clutter on the tab bar...

Reproducible: Always

Comment 1

9 years ago
Please search before you file a bug.

Dupe of bug 334987. See also bug 24418, bug 333208, bug 449336.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334987
(Reporter)

Comment 2

9 years ago
Sorry, searched for the wrong terms (audio background, disable audio, disable sound)

Comment 3

9 years ago
Bug 334987 is for plugins. Bug 449336 would be better.
Duplicate of bug: 449336
You need to log in before you can comment on or make changes to this bug.