Closed Bug 551189 Opened 13 years ago Closed 13 years ago

don't upload native debug symbols in symbol package along with build package

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 561419

People

(Reporter: ted, Unassigned)

Details

Currently we produce a symbol package containing:
a) the breakpad-formatted .sym files
b) the actual debug symbols produced by the compiler (.pdb, debug sections stripped from an ELF binary, or .dSYM)

We then upload the entire contents to the symbol server, as well as uploading the entire zip alongside the build package. The symbol package winds up being huge, mostly due to the native debug symbols being huge. We provide those for the convenience of symbol server users (and they are useful), but for our build infrastructure (unit tests and Talos) they're not useful, and they add download time to the whole process.

We should produce two separate zips: one containing everything that we upload to the symbol server, and one containing just the Breakpad .sym files that we upload along with the build.
catlee filed and fixed this elsewhere.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561419
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.