Email displaying as encoded text instead of image attachment

RESOLVED INCOMPLETE

Status

Thunderbird
Message Reader UI
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Nicholas, Unassigned)

Tracking

({testcase})

x86_64
Windows 7
testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-09-15, URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1025 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100227 Lightning/1.0b1 Thunderbird/3.0.3

I'm using Gmail IMAP through Thunderbird. I sent two emails from my iPhone, each with a single image attached (inline). One can across with an attachment as well as the image displaying in the body of the message. The other came across as base64 encoded text. The "broken" email appears fine when I go to Gmail.com in a browser.

Reproducible: Sometimes

Steps to Reproduce:
I have no clue how to reproduce this. I've noticed it a few times over the last week or two. It seems to happen where there's just one image attached to or in the body of the message and nothing else. 
1) IMAP yourself to a gmail account, then start sending email to yourself with a single image attached (no additional body).
Actual Results:  
Some come across fine, some come across as "--Apple-Mail-1--32521424
Content-Disposition: inline;
	filename=photo.jpg
Content-Type: image/jpeg;
	name=photo.jpg
Content-Transfer-Encoding: base64

/9j/4AAQSkZJRgABAQEASABIAAD/4QLuRXhpZgAATU0AKgAAAAgACgEPAAIAAAAGAAAAhgEQAAIA
AAALAAAAjAEaAAUAAAABAAAAmAEbAAUAAAABAAAAoAEoAAMAAAABAAIAAAExAAIAAAAGAAAAqAEy
AAIAAAAUAAAArgITAAMAAAABAAEAAIdpAAQAAAABAAAAwoglAAQAAAABAAACCAAAAABBcHBsZQBp
UGhvbmUgM0dTAAAAAABIAAAAAQAAAEgAAAABMy4xLjMAMjAxMDowMzowOSAyMDozNTozMAAAFIKa
" garble.

Expected Results:  
It should just display the image in the message body, and show it as an attachment in the email list pane.

What confuses me is that I sent basically the same email twice (just a different photo), one worked and one didn't... and it looks fine in Gmail... yet when one does this, it never "corrects" itself like IMAP sometimes can do.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
Nicholas , can you share a message with us (save it using File -> Save and come back to this page , to use the add an attachment link above) ?

can you provide a screenshot too ?
(Reporter)

Comment 2

8 years ago
Created attachment 444263 [details]
An example of a broken email

Here's an example of an email that isn't displaying correctly in Thunderbird (but displays fine in Gmail through a browser).
(Reporter)

Comment 3

8 years ago
Created attachment 444264 [details]
Screen shot of email attached
(Reporter)

Comment 4

8 years ago
Done! This has been happening about once every 10 emails lately. Not always the same type of content, and not always the same client sending the email.
It sounds Gmil IMAP. Folder of "[Gmail]/All Mail? Or other folder?
"offline use" is on (Folder properties/Synchronization, select this folder for offline use)
What is file size of file for mail folder? (Inbox and Inbox.msf, [Gmail].sbd\All Mail and [Gmail].sbd\All Mail.msf). 
Folder properties, Location: is internal path. Check corresponding file under directory of Account Setting/Server Setting, Location:.

Create an IMAP mail folder, set "offline use"=off, show "Order Received" column at folder pane(value is UID of mail), copy the mail to this folder, Folder Proprties/Rebuild Index, view the mail.
(as new mail in new folder, UID=1 in this folder).
Does the mail displayed correctly?

Can you check location of data of the "garbled displayed mail source" in mail folder file?(Inbox, [Gmail].sbd\All Mail etc.)
Nicholas, please, could answer to questions in comment #5?
Keywords: testcase
Whiteboard: closeme 2010-09-15
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.