Compose: make only the first recipient To: and subsequent CC:

RESOLVED WONTFIX

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: Arie Skliarouk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8
Build Identifier: 

When composing an email, Thunderbird makes everyone a "To:", rather than the first one being a To and everyone else a Cc.


Reproducible: Always

Steps to Reproduce:
1. Start composing new email
2. Write name of the first recipient and press ENTER
3. Observe the second recipient to be marked as "To:" instead of "Cc:"



This is the behavior of Outlook and kmail. If you think the behavior is not worthy for general public, make an configuration knob to force it.

Updated

8 years ago
Assignee: ui → nobody
Component: User Interface → General
Product: Bugzilla → Thunderbird
QA Contact: default-qa → general
(Reporter)

Updated

8 years ago
Component: General → Message Compose Window
Version: unspecified → 2.0

Updated

8 years ago
Severity: trivial → enhancement

Comment 1

8 years ago
was WONTFIXéd in bug 310527
QA Contact: general → message-compose

Comment 2

8 years ago
This would only make sense if multiple comma-separated addresses entered into a single line would reliably auto-completed, which is currently not the case in Thunderbird 3.x due to bug 528503.

Comment 3

8 years ago
I would REALLY like this feature, and would come into play 50 times a day for me. Please?  : )
In line with comment 1 and comment 2, recommending wontfix.

In the current traditional single-address per line design, worse with bug 392932 and bug 528503, this doesn't make sense.
Implementing this RFE is much more likely to cause inconvenience to a larger group of users who need multiple to-recipients or just multiple of any same sort of recipient.
And if we give up the current design in favor of comma-separated lists, this will no longer be relevant.

Easy workaround:
- type to-address, press Enter
- change second recipient line to CC
- type cc-address, press Enter
-> any subsequent entries will be CC

So basically, it's just one extra click to get the behaviour you want.
Whiteboard: [wontfix?][closeme 2013-01-14]

Comment 5

5 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Whiteboard: [wontfix?][closeme 2013-01-14]
You need to log in before you can comment on or make changes to this bug.