Create duplicate email via deleting attachment

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: dah8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-09-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

I was able to unintentionally duplicate an email by moving it to a new folder just after asking for its attachment to be deleted.

Reproducible: Always

Steps to Reproduce:
1. Open an email with an attachment (from IMAP in my case)
2. Delete the attachment (right click, delete, etc.)
3. Close the email
4. Drag the email to a new folder
Actual Results:  
Email is copied to new folder

Expected Results:  
Email is moved to the new folder

Updated

9 years ago
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
David can you reproduce easily ? and Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)

Id you can easily reproduce in safe mode , could you generate Imap logs  as described at https://wiki.mozilla.org/MailNews:Logging ?
(Reporter)

Comment 2

8 years ago
I am able to reproduce this;  the attachment deletion takes a while (10-20 seconds maybe?) so there is ample opportunity to try it.

I haven't had a chance to try with safe mode / logging yet but I will do that and follow up.

Comment 3

7 years ago
Do you still see this issue when using version 5 or 6 (due out a week)?
- If you no longer see the problem, please set status to RESOLVED, and set resolution to WORKSFORME.
- If you still see the problem, please provide updated details, and any additional steps needed to reproduce the problem.
Whiteboard: [closeme 2011-09-01]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.