Closed Bug 551443 Opened 10 years ago Closed 10 years ago

Drag file to email window text pane leaves local path

Categories

(Thunderbird :: General, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 113435

People

(Reporter: dah8, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

If you drag a file to the email window but drop it in the text pane instead of the little attachment space that opens up, a URL to the local path of the file is inserted instead.  The file is not attached.

The string is something like:

file://C:/Users/Dave/.......

I can't see the purpose of emailing someone the local path of a file... it seems far more likely that the file was meant to be attached.

As far as I recall Outlook, for example, attaches the file wherever in the window the mouse is when you drop it.  That seems far more useful and intuitive.

Also, even if you *wanted* the path of the file for some reason, the text as inserted is in a URL format and is also encoded.  So this makes it less readable (assuming that someone reading it was what was intended).


Reproducible: Always
Duplicate of MailNews Core bug 241572 comment 5 -> MailNews Core bug 113435.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 113435
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.