RFE: Capture "click-on-link" in Acrobat Plug-in to use Firefox (and NOT IE, even if that is default)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
enhancement
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Rob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2pre) Gecko/20100302 Namoroka/3.6.2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2pre) Gecko/20100302 Namoroka/3.6.2pre

RFE: 

I call this an RFE since I would prefer existing (and likely working for most people) operation of the Browser to be altered, otherwise this would be a Bug.  ;)


* I suggest we need to capture the "click-on-link" in the Acrobat Plug-in to use Firefox (and NOT IE, even if that is default for the Target or the URL) to open the link.


Why:

I use Windows, that Operating System and many programs work better if you set Internet Explorer as the "Default Browser" (even if you use Firefox as your "preferred Browser"). Firefox would need to be 100% identical to IE (Bugs and all) to resolve that issue.


If you have the Acrobat Plug-in for Firefox (Namoroka) installed, open an URL to a .PDF file and click on a link in the PDF then Internet Explorer will open the URL (assuming it is your Default Browser).

This mode of operation _differs_ from what one would expect had they clicked on a link in any other Tab (that you would go to that URL, (or if 'Javascripted' (etc.), that a New Window would open)).


One might argue this is a Bug, that for Accessibility reasons we _must_ provide either:

1. Some means for (visually impaired) people to know that they are on a Tab that is a PDF file and thus any links clicked on will open in a different program (unexpected ?).

2. Force links in PDFs to simply open in a new Tab (or the same Tab) in the same manner as if a link were clicked on any other Tab - do not make the HMI different for the PDF Plug-in.


Thanks,
Rob


Reproducible: Always




RFE
(Reporter)

Comment 1

8 years ago
I have been testing for the past few days and from what I can tell this seems to have been fixed within the last 4-5 days.

Thank you whomever,
Rob

Closed, FIXED
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 2

7 years ago
please use WORKSFORME rather than FIXED when it's not known what patch or other bug fixed the issue.  (or INVALID if it was determined that the issue was not a bug, or not caused by Firefox)
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.