If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

regression scripts don't alert about regressions in trace-malloc, codesighs, or other non-talos test numbers

RESOLVED FIXED

Status

Release Engineering
General
--
major
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: dbaron, Assigned: catlee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The regression email scripts that catlee wrote that send email to dev-tree-management about talos regressions don't send any email about trace-malloc test regressions.  Since people don't actually look at the graph server anymore, this means that regressions in those tests are going completely undetected.

And since they're *much* easier to fix when we still have the logs of the builds (which have good data in them), this is a big problem, since those logs get deleted after two weeks.

The regression scripts should send email about regressions in the trace-malloc test numbers.
Off to john for prioritization
Assignee: nobody → joduinn

Comment 2

7 years ago
This almost caused us to ship a huge leak regression in Firefox 4 Beta 1 :(
Summary: regression scripts don't alert about regressions in trace-malloc test numbers → regression scripts don't alert about regressions in trace-malloc, codesighs, or other non-talos test numbers
Duplicate of this bug: 579134

Comment 4

7 years ago
I think this is pretty important. bhearsum says if we fix this then we can have codesighs, leak tests, and ctor monitored.

Updated

7 years ago
Blocks: 579131
(Assignee)

Comment 5

7 years ago
We started ignoring Trace Malloc.*, Codesighs, Refcnt Leaks in July 2009 (http://hg.mozilla.org/graphs/rev/ab46c631d2af), but I can't find any reference as to why.

Which of these should be enabled again?
(Assignee)

Comment 6

7 years ago
Now spamming dev.tree-management again.
Assignee: joduinn → catlee
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering

Comment 7

2 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/f242b6080e6fd8fcf82295b26983d1ed022aafa8
Bug 551531: re-enable leak test regression monitoring.

--HG--
branch : 1.0
You need to log in before you can comment on or make changes to this bug.