The package.json files that the SDK currently uses are manifests, and the most descriptive and memorable name for them would be manifest.json. The SDK used to use that name, and it's not clear why it doesn't anymore. Maybe there's a good reason, and this bug should be wontfixed. But otherwise, it seems like we should be calling these files manifest.json.
The reason the package structure is a bit counterintuitive at times is because it was originally lifted from narwhal , largely because a CommonJS package format hadn't been decided on at the time and I'd assumed that narwhal's would be used as the basis if a CommonJS packaging format ever did arise. One eventually did, actually: http://wiki.commonjs.org/wiki/Packages/1.0 This is pretty similar to what we've currently got set up, and as packages are the smallest unit of redistributable code+documentation+tests, we should actually probably modify our package structure to fit with this better, so that our packages are interoperable with those from other JS frameworks and vice versa. I wanted to do this pre-0.1 but never got around to it.  http://narwhaljs.org/
(In reply to comment #1) > as packages are > the smallest unit of redistributable code+documentation+tests, we should > actually probably modify our package structure to fit with this better, so that > our packages are interoperable with those from other JS frameworks and vice > versa. That makes some sense, in which case this bug should probably be wontfix. > I wanted to do this pre-0.1 but never got around to it. It's not too late! We can make such changes, although we should probably deprecate the existing structure when we introduce the new one rather than simply removing support for it immediately. Do you have a bug on it?
Just filed one as Bug 552841.
The CommonJS standard calls the manifest package.json, and our plan is to follow that standard, so we should call our manifest package.json too.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product. To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.