Disabled mail Toolbar not saved

RESOLVED WORKSFORME

Status

Thunderbird
Toolbars and Tabs
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Thomas Winteler, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2) Gecko/20100301 Ubuntu/9.10 (karmic) Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.8) Gecko/20100227 Thunderbird/3.0.3

A disabled Mail Toolbar is enabled after TB restart. The setting will not be saved.
Other users that have the same Problem:
http://getsatisfaction.com/mozilla_messaging/topics/my_thunderbird_3_0_1_mail_toolbar_resets_whenever_i_restart_thunderbird

Other Problem is, that i need to do the process to disable the Mail Toolbar twice, that it is disabled.

Thanks for Help

Kind regards
thomi

Reproducible: Always

Steps to Reproduce:
1. disable Mail Toolbar
2. close Thunderbird
3. start Thunderbird
4. Mail Toolbar is enabled
Actual Results:  
The setting, that the Mail Toolbar is disabled will not be saved.

Expected Results:  
Save the setting, that the Mail Toolbar is disabled.

Comment 1

8 years ago
I have the same issue, as do many others on the forum.  Why hasn't this ticket been looked at?  Pretty basic functionality guys...
Keywords: qawanted
(Reporter)

Comment 2

8 years ago
still have the same problem.. working with:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.10) Gecko/20100528 Thunderbird/3.0.5
This wfm on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:2.0b2pre) Gecko/20100701 Shredder/3.2a1pre. Do you have any themes extension installed ?

Anything showing up in Tools -> Error console ?
(Reporter)

Comment 4

8 years ago
hello

here are my tb addons/themes:
http://imagebin.ca/view/ndc3I00.html
http://imagebin.ca/view/QpZApOm.html

and the error console.. but nothing happend in the error console if i switch mail-toolbar on/off:
http://imagebin.ca/view/tIHJs8N.html
(Reporter)

Comment 5

8 years ago
good morning

have upgraded to kubuntu 10.04's thunderbird 3.0.7.. still have the same problem... why wouldn't this be fixed???

thomi
(In reply to comment #5)
> good morning
> 
> have upgraded to kubuntu 10.04's thunderbird 3.0.7.. still have the same
> problem... why wouldn't this be fixed???

Because we need to understand what's going on first. Does this happens on a clean (eg new profile ) too ?
(Reporter)

Comment 7

8 years ago
good morning

OK.. no i have 3.0.8, and still same problem...

It happens only in my current profile, upgraded from tb2.
If i create a new, clean profile, the Mail Toolbar settings will be saved.

What Files/Information you need to get this fixed?

Thanks for response

kind Regards from Switzerland
thomi
So localstore.rdf and prefs js are the things to look at. if you delete/rename the localstore.rdf file in you profile does the issue go away ?
(Reporter)

Comment 9

8 years ago
good morning

Have done that, first saved the whole profile folder and then deleted localstore.rdf. But same Problem. Thunderbird starts with enabled Mail-Toolbar, i disable it, restart Thunderbird -> Mail-Toolbar still enabled.

What information, files hsould i send here? Can i send eg. my whole Profie folder to you, Ludovic? No Problems with that, cause the Mail-Store it self is outside the Profile folder.

Thanks for response
thomi
send me the prefs.js file I'll have a look - be sure to mention the bug number.
(In reply to comment #10)
> send me the prefs.js file I'll have a look - be sure to mention the bug number.

I'm not seeing anything obvious in the file sent by Thomas :(

I see that I didn't ask thomas if he had tried in -safemode (http://support.mozillamessaging.com/en-US/kb/Safe+Mode) ?
(Reporter)

Comment 12

8 years ago
hi

i tried also in -safe-mode before, without success...
If i create a new profile, i can disable the mail toolbar and it will be saved. I think, the problem is in my profile, that is very old, upgrading from different versions. If i have time, i will create a complete new profile and check back.
But if there is a solution, let me now.

kind regards
thomi
(Reporter)

Comment 13

8 years ago
good morning..

ha... solved ;)... don't know how.. an update from tb or any addon.. but, now it is solved.. in my case..

have a nice day..
thomi
(In reply to comment #13)
> good morning..
> 
> ha... solved ;)... don't know how.. an update from tb or any addon.. but, now
> it is solved.. in my case..
> 
> have a nice day..
> thomi

Thanks for the update Thomi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.