Set uninstall survey url to new url

RESOLVED FIXED in Thunderbird 3.1b2

Status

Thunderbird
Installer
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: rebron, Assigned: standard8)

Tracking

Thunderbird 3.1b2
x86
Mac OS X
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(thunderbird3.1 beta2-fixed, blocking-thunderbird3.0 .4+, thunderbird3.0 .4-fixed)

Details

(Whiteboard: [funnelcake][conversion funnel][has patch needs review])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Need to set uninstall survey url to new url
(Reporter)

Updated

8 years ago
blocking-thunderbird3.0: --- → ?
(Reporter)

Updated

8 years ago
Whiteboard: [funnelcake] [conversion funnel]
(Assignee)

Comment 1

8 years ago
Rafael: once you know the url, assign to me and I'll do the patch.
Assignee: nobody → rebron
Blocks: 551720
blocking-thunderbird3.0: ? → .4+
(Assignee)

Comment 2

8 years ago
Per irc the url to use is:

http://live.mozillamessaging.com/survey/uninstall/
Assignee: rebron → bugzilla
(Assignee)

Comment 3

8 years ago
Created attachment 432639 [details] [diff] [review]
The fix

Late decision on irc will be to use:

http://live.mozillamessaging.com/survey/uninstall/?locale=${AB_CD}&version=${AppVersion}

Therefore patch attached to make that change. I've not tested this yet, but I've just set off a try server build and would like to get it in for tomorrow's nightly (if the try server build works).
Attachment #432639 - Flags: review?(bienvenu)
(Assignee)

Updated

8 years ago
Whiteboard: [funnelcake] [conversion funnel] → [funnelcake][conversion funnel][has patch needs review]

Comment 4

8 years ago
Comment on attachment 432639 [details] [diff] [review]
The fix

looks reasonable, as long as the try server builds do the right thing, which I'll trust you to verify :-)
Attachment #432639 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 5

8 years ago
The try server builds do the right thing on XP and below. Vista and above (I think) need a new bug which I'll raise in a while.
(Assignee)

Comment 6

8 years ago
Comment on attachment 432639 [details] [diff] [review]
The fix

a=Standard8 for checkin of simple url change for the uninstallers.
Attachment #432639 - Flags: approval-thunderbird3.0.4+
(Assignee)

Comment 7

8 years ago
Checked into trunk and 3.0 branch:

http://hg.mozilla.org/comm-central/rev/742aaabc8e7e
http://hg.mozilla.org/releases/comm-1.9.1/rev/0cf6c561fbca
Status: NEW → RESOLVED
Last Resolved: 8 years ago
status-thunderbird3.0: --- → .4-fixed
status-thunderbird3.1: --- → beta2-fixed
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1b2
(Assignee)

Updated

8 years ago
Duplicate of this bug: 550313
You need to log in before you can comment on or make changes to this bug.