AMO doesn't recognize MozillaDeveloperPreview as a version of Firefox

RESOLVED DUPLICATE of bug 545048

Status

RESOLVED DUPLICATE of bug 545048
9 years ago
3 years ago

People

(Reporter: SonicTheHedgehogffansyt, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3
Build Identifier: Firefox3.7 Alpha 2

When I try to download a new add-on for Mozilla 3.7 alpha 2 it says I need to download Firefox!
I had to downgrade to 3.6
It's OK I like 3.6 better

Reproducible: Always

Steps to Reproduce:
1.Downgrade to 3.6
2.
3.
Actual Results:  
It worked

Expected Results:  
the alpha2 3.7 Firefox should have downloaded my add-on!

ya
What specifically says you have to download Firefox? The web page?
(Reporter)

Comment 2

9 years ago
Yes, the web page
Component: Installer → Public Pages
Product: Firefox → addons.mozilla.org
QA Contact: installer → web-ui
It would be helpful if you included a link to the specific web page for the specific addon that required you to downgrade.

Having said that, this isn't particularly surprising -- addons authors have to explicitly opt-in their add-ons to newer versions of Firefox, once they've verified that it works correctly.

(Consider an extreme case: addons designed for Firefox 1.0 that have never changed since then are highly likely to break in Firefox 3.x.  In the same sense, addons that work for Firefox 3.6 may break in Firefox 3.7)

Your particular experience just means that the author of the addon you're interested in hasn't tested the addon with 3.7a2 and resubmitted it with the flag for "ok in 3.7" flag enabled

Resolving as INVALID, since this isn't a bug in addons.mozilla.org.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
I'm not convinced this should be invalid. If the message is download Firefox it should at least be customized to state the reason they are asked to download Firefox... just stating download Firefox seems wrong if they are running Firefox. Then again, I haven't seen the message so perhaps it is informative enough.
Created attachment 432046 [details]
screenshot of message

Yup, I was mistaken -- this is a valid bug after all.  Just tried to install Adblock Plus in 3.7a2, and it gave a silly message:
===
To install Adblock Plus and thousands of other Firefox add-ons, get Firefox, a free and open web browser from Mozilla. To learn more about Firefox and how it can make your internet experience better, click the button below.
===
URL: https://addons.mozilla.org/en-US/firefox/addon/1865

Note that Adblock Plus is marked as supporting versions up to 3.7a3pre, so it should be fine in 3.7a2. Works fine in mozilla-central nightlies, so this is probably just a user-agent-checking bug (i.e. amo recognizes "Minefield" and "Firefox" and probably "Shiretoko", but not "MozillaDeveloperPreview")

Screenshot of bug attached.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: When I try to download a new add-on for Mozilla 3.7 alpha 2 it says I need to download Firefox! → AMO doesn't recognize MozillaDeveloperPreview as a version of Firefox
OS: Windows Vista → All
Hardware: Other → All
STR, if it's not clear from comment 5:
 1. Load URL https://addons.mozilla.org/en-US/firefox/addon/1865
 2. Click big green "Download Now" button
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545048
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.