mozilla-runtime expected at wrong location

RESOLVED DUPLICATE of bug 542053

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 542053
8 years ago
8 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
mozilla-runtime is expected just besides the main process executable apparently:
http://mxr.mozilla.org/mozilla-central/source/ipc/glue/GeckoChildProcessHost.cpp#182

This is at least not true for xulrunner environments (e.g. with Fennec and for Linux distributions shipping Firefox as split package XR+Firefox).

Comment 1

8 years ago
Indeed, although for some reason I thought cjones had fixed this along the way. We should be using a path relative to NS_GRE_DIR.
I thought dougt was going to patch this, since it broke in Fennec when it was using xulrunner, but maybe he never got around to it.

Comment 3

8 years ago
I moved over to not using XR.  Prior to that move, i was doing something like:

export LD_LIBRARY_PATH=.:./xulrunner
xulrunner/xulrunner application.ini

Comment 4

8 years ago
So we have two problems: 1) can't find mozilla-runtime 2) have to set up LD_LIBRARY_PATH in order to launch it. I think we can solve both of these problems in the code.
Anything here not covered by bug 542053?  It has a WIP patch and everything.
I knew dougt had looked at this!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542053
You need to log in before you can comment on or make changes to this bug.