Delete Calendar command should be disabled if only one calendar exists (won't work because deleting the last calendar is forbidden)

RESOLVED DUPLICATE of bug 518112

Status

Calendar
General
--
minor
RESOLVED DUPLICATE of bug 518112
8 years ago
7 years ago

People

(Reporter: emily chen, Unassigned)

Tracking

Lightning 1.0b1

Details

(Reporter)

Description

8 years ago
1. Create three calendars, local or network is fine 
2. You can delete any two calendars
3. Click on the last one calendar, right click and select "Delete Calendar"

Results: nothing happened. Can not delete the only calendar 

Expected Results: 
1. User can delete it 
2. If the last calendar is designed to be not deleted, should at least pop out a dialog to inform user about it.
Is the "Delete Calendar" menuitem enabled on the last calendar?  We do not support removing all calendars.

Comment 2

8 years ago
This is the intended behavior.
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> Is the "Delete Calendar" menuitem enabled on the last calendar?  We do not
> support removing all calendars.

Yes, it is enabled. You can select "Delete Calendar" on the last one. 

If this is the intended behavior, need to disable "Delete Calendar" on the last Calendar.

Updated

8 years ago
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Solaris → All
Hardware: x86 → All
Summary: Can not delete calendar if it is the only one in Lightning → Delete Calendar command should be disabled if only one calendar exists (won't work because deleting the last calendar is forbidden)
Fixed by bug 518112. Thanks for reporting!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518112
You need to log in before you can comment on or make changes to this bug.