Closed Bug 551945 Opened 12 years ago Closed 12 years ago

gfxWindowsNativeDrawing::IsDoublePass currently always returns true

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bas.schouten, Assigned: bas.schouten)

References

Details

Attachments

(1 file)

Attached patch Fix IsDoublePassSplinter Review
Due to a mistake in the patch to bug 549056 currently IsDoublePass always returns true.

This patch fixes it.
Attachment #432129 - Flags: review?(jfkthame)
Attachment #432129 - Flags: review?(jfkthame) → review+
Duplicate of this bug: 552052
I just made a fresh clobber build and it still doesn't seem to fix the problem with weatherbug.
(In reply to comment #2)
> I just made a fresh clobber build and it still doesn't seem to fix the problem
> with weatherbug.

You sure you did everything right? (i.e. didn't accidentally open another window of an existing FF instance or something like this?) Weatherbug is fixed for me and anyone else I asked?
Duplicate of this bug: 552111
http://hg.mozilla.org/mozilla-central/rev/3f7f0781120f
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to comment #4)
> *** Bug 552111 has been marked as a duplicate of this bug. ***

Pfff I searched for this thing and couldnt find it. Please, if possible use summaries that are easier to find or some keywords, thanks in advance.
(In reply to comment #3)

> You sure you did everything right? (i.e. didn't accidentally open another
> window of an existing FF instance or something like this?) Weatherbug is fixed
> for me and anyone else I asked?

I tried with an empty profile, no other instances running and the same result.  The only possibility I can come up with is maybe it's a bug with flash pre-release 3?
If this is D2D, you should try in normal(non-D2D) FF while having it with opacity: 0.5 to see if that is also broken. If that's the case (or if you're not running D2D already, but this seems unlikely) we might have a general problem with pre-release 3.
yeah this bug isn't completely fixed.  Sometimes while the page is loading you can see the black background instead of seeing through the content.  Sometimes when this happens the black will disappear when the page finishes loading but not always, switching tabs and then back seems to fix it then.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Yes, for me at least, when I turn off direct2d, the transparency problem seems to be gone.  I ran my build on another machine w/o pre-release 3 and direct2d enabled and there were no problems there either.
If this happens with D2D a seperate bug should be opened for that. Important is to know if it works right with GDI, this bug affected GDI rendering as well. This problem is fixed.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.