builds doing trace-malloc or codesighs fail on the first run for a new branch

RESOLVED WONTFIX

Status

P4
normal
RESOLVED WONTFIX
9 years ago
4 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [automation])

(Reporter)

Description

9 years ago
There a different logs that are downloaded during a debug build that at the end of the run will get uploaded to ftp. The next debug will download the logs from the previous debug build.

This means that the first run ever doesn't have logs to download and will go red. Even if it goes red it finishes the whole build which is the right way.

The problem in here is that it confuses people when they see their first debug builds going red and they are not sure why.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [automation]
Duplicate of this bug: 659815
Not really all debug (we don't do trace-malloc on 10.6), nor just debug (since we do codesighs on opt Linux and Mac).
Summary: debug builds for all platforms fail on the first run for a new branch → builds doing trace-malloc or codesighs fail on the first run for a new branch
We could use conditional buildbot steps here like we do for creating updates.
assigned during triage; if you think this is better assigned to someone else, please swap with them for another old bug.
Assignee: nobody → nrthomas
Ted, will bug 668219 rip out the log uploading and downloading ? At the moment I think we're calculating Zdiff but not using it for anything, and not calculating the delta makes life easier here.
That bug would get rid of the codesighs stuff (like Zdiff), but not the tracemalloc stuff.

Updated

7 years ago
Assignee: nrthomas → edransch

Updated

6 years ago
Assignee: edransch.contact → nobody
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.