Greek text search doesn't work with diacritics

RESOLVED DUPLICATE of bug 202251

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 202251
8 years ago
7 years ago

People

(Reporter: Dimitris D, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100207 Namoroka/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2) Gecko/20100207 Namoroka/3.6

Ancient and modern greek uses diacritics.
When i text search greek words without diacritics it finds the words without diacritics and with the diacritic tonos but doesn't find the ancient greek diacritics from unicode U+03B1 to U+03A9.



Reproducible: Always

Steps to Reproduce:
1. Visit http://www.polytoniko.org/mathi1.php?newlang=en&font=Palatino+Linotype&right=no
2. Ctrl+F write των and highlight.

Actual Results:  
 Words like τῶν aren't highlighted.

Expected Results:  
The expect result is to highlight all the text which has "των" where "ω" could be any of "ΩωΏώὠὡὢὣὤὥὦὧὼώᾠᾡᾢᾤᾥᾦᾧᾨᾩᾪᾫᾬᾭᾮᾯῲῳῴῶῷῺΏῼ".
(Reporter)

Updated

8 years ago
Summary: Greek text search doesn't work diacritics → Greek text search doesn't work with diacritics

Comment 1

8 years ago
I think that you have misunderstood the functionality here, the expected results in your example would be to highlight all the text that has "των", where "ω" could be any of "Ωω" depending on the character match setting. All the rest characters are different, and therefor should not be highlighted.
I would consider a bug your claim that words are highlighted no matter if you search with or without the diacritic tonos but i couldn't reproduce that neither on Namoroka, nor on Minefield (not even on stable).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 202251
You need to log in before you can comment on or make changes to this bug.