Using middle-click or the context menu to close a tab, the content remains and no tab is selected

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Daniel de Wildt, Unassigned)

Tracking

({hang})

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
It is possible to close a tab, but without terminating the html-session.
The page-content is still shown. (Tested with FF 3.5 & 3.6)

Reproduce:
* Enable javascript
* Open tab one with some content.
* Open tab second and go to the URL https://www.commerzbanking.de/
* Enter one digit in the field 'Anmeldename' (in the upper-right, below 'Online Banking')
* Close the second tab with a middle mouse-click.

Result:
* a modal (javascript) dialog appears with a warning that you entered a wrong username.
* If you close that dialog, the tab is closed, but the page content is still shown.

Expected:
* No modal dialog and a closed tab, showing the previous tab.
Confirmed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.2pre) Gecko/20100311 Namoroka/3.6.2pre ID:20100311033849

Running the same steps in Shiretoko results in a complete freeze for me. After the modal dialog has been confirmed twice it stays open blank. Nothing can be clicked anymore and the user is forced to restart the browser.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang
OS: Windows XP → All
Hardware: x86 → All
Summary: Tab is closed, but the content is still shown → Using middle-click or the context menu to close a tab, the content remains and no tab is selected
Version: unspecified → 3.5 Branch

Comment 2

5 years ago
I can't reproduce. Do you still see this?  If not, please close.
Flags: needinfo?(hskupin)
Flags: needinfo?(dewildt)
(Reporter)

Comment 3

5 years ago
It's possible to close the tab without any problems.
=> Closing this bug as requested.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(hskupin)
Flags: needinfo?(dewildt)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.