Feature Request re mail notifications

RESOLVED DUPLICATE of bug 438441

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 438441
8 years ago
8 years ago

People

(Reporter: rchost, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Build Identifier: version 2.0.0.23 (20090812)

At present, it is possible to play a system default or user-selected audio file on receiving an email. That's great! However, the reality is that I - and surely many other Thunderbird users, have a variety of subscriptions to newsgroups and forums that flood our inboxes that don't merit an audio notification. For instance, I subscribe to technical groups for Ant, Tomcat, and various other technologies. Also, I get my fair share of spam. I use message filters to delete spam and to file the various emails that result from subscriptions in appropriate folders where I will look at them at my convenience. I don't want the audio notification to occur for spam or for subscription items that arrive in my inbox, just for "real" mail, the stuff that isn't a subscription or spam. 

Reproducible: Always

Steps to Reproduce:
1. Set the mail notification sound to either the system default or a user-selected audio file.
2. Make sure that you have subscriptions to user groups that have a moderate to high amount of traffic. 
3. Wait a bit. Any subscription email that comes in, plus any spam that arrives, will trigger the audio notification that you set up in Step 1.

If you're like me, you DON'T want audio notifications for subscription mail or spam.

Actual Results:  
I got notifications for every email that arrived in my inbox INCLUDING subscription mail and spam. 

Expected Results:  
Same as expected results. 



In my case, I would be perfectly happy if I got audio notifications only for mail that wasn't spam (or suspected spam) or subscribed mail. But, given that some people might want to know about the arrival of spam and subscribed mail, why not make that a possibility in the options? Give users the choice of which sorts of mail they want audio notifications for. Ideally, you could even let them choose DIFFERENT notifications for each class of mail. For example, if spam comes in, the notification might be "You've got spam!"; if subscribed mail comes in, the notification might be "A subscribed email (maybe specifying the mailing list name?) just arrived"; anything else might get a notification of "a personal email has just arrived".
This appears to be the current request to dupe bugs to.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 438441
You need to log in before you can comment on or make changes to this bug.