If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash on close of message window

VERIFIED DUPLICATE of bug 54792

Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 54792
17 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: scottputterman)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

on my branch build, I crash when I send messages.  

it seems to happen when I'm copying into the sent folder.

take a look at the whole stack, not just the top.  it looks fishy to me.

NTDLL! 77f7629c()
js_AllocGCThing(JSContext * 0x02f7c110, unsigned int 0) line 381 + 41 bytes
js_NewObject(JSContext * 0x02f7c110, JSClass * 0x01259080 struct JSClass  
KeyEventClass, JSObject * 0x00d714f0, JSObject * 0x00000000) line 1440 + 11 
bytes
JS_NewObject(JSContext * 0x02f7c110, JSClass * 0x01259080 struct JSClass  
KeyEventClass, JSObject * 0x00d714f0, JSObject * 0x00000000) line 1892 + 21 
bytes
NS_NewScriptKeyEvent(nsIScriptContext * 0x02f7c2c0, nsISupports * 0x04e56074, 
nsISupports * 0x00000000, void * * 0x0012cf60) line 1014 + 23 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x04e56074) line 141 + 25 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x04110b70, 
nsIDOMEvent * 0x04e56074, nsIDOMEventTarget * 0x036b2b48, unsigned int 2, 
unsigned int 7) line 788 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x02f7c5d0, nsEvent * 
0x0012d974, nsIDOMEvent * * 0x0012d6c0, nsIDOMEventTarget * 0x036b2b48, unsigned 
int 7, nsEventStatus * 0x0012d998) line 1207 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x036b2b40, nsIPresContext * 
0x02f7c5d0, nsEvent * 0x0012d974, nsIDOMEvent * * 0x0012d6c0, unsigned int 1, 
nsEventStatus * 0x0012d998) line 3321
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x039f7708, 
nsIPresContext * 0x02f7c5d0, nsEvent * 0x0012dcc0, nsIFrame * 0x00d6d828, 
nsEventStatus * 0x0012dc28, nsIView * 0x02f9c330) line 563
PresShell::HandleEventInternal(nsEvent * 0x0012dcc0, nsIView * 0x02f9c330, 
unsigned int 1, nsEventStatus * 0x0012dc28) line 4249 + 43 bytes
PresShell::HandleEvent(PresShell * const 0x02f9dc54, nsIView * 0x02f9c330, 
nsGUIEvent * 0x0012dcc0, nsEventStatus * 0x0012dc28, int 1, int & 1) line 4190 + 
25 bytes
nsView::HandleEvent(nsView * const 0x02f9c330, nsGUIEvent * 0x0012dcc0, unsigned 
int 28, nsEventStatus * 0x0012dc28, int 1, int & 1) line 379
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x02f9c510, nsGUIEvent * 
0x0012dcc0, nsEventStatus * 0x0012dc28) line 1439
HandleEvent(nsGUIEvent * 0x0012dcc0) line 68
nsWindow::DispatchEvent(nsWindow * const 0x02f9c1f4, nsGUIEvent * 0x0012dcc0, 
nsEventStatus & nsEventStatus_eIgnore) line 681 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012dcc0) line 702
nsWindow::DispatchFocus(unsigned int 108) line 4039 + 15 bytes
nsWindow::ProcessMessage(unsigned int 8, unsigned int 592314610, long 0, long * 
0x0012e004) line 3099 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x050d0106, unsigned int 8, unsigned int 
592314610, long 0) line 950 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e8a5c0()
USER32! 77e82d7c()
USER32! 77e720ff()
USER32! 77e82832()
USER32! 77e8903f()
USER32! 77e8ad30()
USER32! 77e8b044()
USER32! 77e8aed8()
USER32! 77e8b203()
USER32! 77e8a5a6()
nsDebug::Assertion(const char * 0x01360d20, const char * 0x100c64b4, const char 
* 0x01360cec, int 347) line 215 + 22 bytes
nsDebug::NotReached(const char * 0x01360d20, const char * 0x01360cec, int 347) 
line 414 + 22 bytes
nsHTMLEditor::~nsHTMLEditor() line 347 + 21 bytes
nsHTMLEditorLog::~nsHTMLEditorLog() line 51 + 22 bytes
nsHTMLEditorLog::`scalar deleting destructor'() + 15 bytes
nsEditor::Release(nsEditor * const 0x049c3770) line 954 + 158 bytes
nsHTMLEditor::Release(nsHTMLEditor * const 0x049c3770) line 353 + 12 bytes
nsHTMLEditorLog::Release(nsHTMLEditorLog * const 0x049c3770) line 54 + 12 bytes
nsCOMPtr<nsIHTMLEditor>::~nsCOMPtr<nsIHTMLEditor>() line 490
nsEditorShell::~nsEditorShell() line 270 + 163 bytes
nsEditorShell::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsEditorShell::Release(nsEditorShell * const 0x04d2e050) line 273 + 157 bytes
nsXPCWrappedNative::~nsXPCWrappedNative() line 398 + 27 bytes
nsXPCWrappedNative::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsXPCWrappedNative::Release(nsXPCWrappedNative * const 0x04d2ffc0) line 71 + 31 
bytes
nsXPCWrappedNative::JSObjectFinalized(JSContext * 0x03a3d390, JSObject * 
0x0443e9d8) line 96
WrappedNative_Finalize(JSContext * 0x03a3d390, JSObject * 0x0443e9d8) line 783
js_FinalizeObject(JSContext * 0x03a3d390, JSObject * 0x0443e9d8) line 1600 + 114 
bytes
gc_finalize_phase(JSContext * 0x03a3d390, unsigned int 352) line 907 + 11 bytes
js_GC(JSContext * 0x03a3d390, unsigned int 0) line 1173 + 13 bytes
js_ForceGC(JSContext * 0x03a3d390) line 871 + 11 bytes
js_DestroyContext(JSContext * 0x03a3d390, int 2) line 219 + 9 bytes
JS_DestroyContext(JSContext * 0x03a3d390) line 832 + 11 bytes
nsJSContext::~nsJSContext() line 366 + 13 bytes
nsJSContext::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsJSContext::Release(nsJSContext * const 0x03a3d9a0) line 374 + 154 bytes
nsCOMPtr<nsIScriptContext>::assign_assuming_AddRef(nsIScriptContext * 
0x00000000) line 472
nsCOMPtr<nsIScriptContext>::assign_with_AddRef(nsISupports * 0x00000000) line 
849
nsCOMPtr<nsIScriptContext>::operator=(nsIScriptContext * 0x00000000) line 584
nsDocShell::Destroy(nsDocShell * const 0x048c75e4) line 1614
nsWebShell::Destroy(nsWebShell * const 0x048c75e4) line 1393
nsXULWindow::Destroy(nsXULWindow * const 0x048b1c04) line 324
nsWebShellWindow::Destroy(nsWebShellWindow * const 0x048b1c04) line 1779
nsChromeTreeOwner::Destroy(nsChromeTreeOwner * const 0x048c7284) line 217
nsMsgCompose::CloseWindow(nsMsgCompose * const 0x04d2d3a0) line 839 + 12 bytes
nsMsgComposeSendListener::OnStopCopy(nsMsgComposeSendListener * const 
0x04e565a4, unsigned int 0) line 1767
nsMsgComposeAndSend::NotifyListenersOnStopCopy(nsMsgComposeAndSend * const 
0x04e562c0, unsigned int 0) line 3419
CopyListener::OnStopCopy(CopyListener * const 0x04e638f0, unsigned int 0) line 
142
nsMsgCopyService::ClearRequest(nsCopyRequest * 0x04e61e70, unsigned int 0) line 
160
nsMsgCopyService::NotifyCompletion(nsMsgCopyService * const 0x03a4d600, 
nsISupports * 0x04e60570, nsIMsgFolder * 0x02f59a6c, unsigned int 0) line 436
nsImapMailFolder::ClearCopyState(unsigned int 0) line 4342
nsImapMailFolder::OnStopRunningUrl(nsImapMailFolder * const 0x02f59ae4, nsIURI * 
0x04e65e14, unsigned int 0) line 3415
nsUrlListenerManager::BroadcastChange(nsIURI * 0x04e65e14, nsUrlNotifyType 
nsUrlNotifyStopRunning, unsigned int 0) line 97
nsUrlListenerManager::OnStopRunningUrl(nsUrlListenerManager * const 0x04e65dd0, 
nsIMsgMailNewsUrl * 0x04e65e14, unsigned int 0) line 110 + 18 bytes
nsMsgMailNewsUrl::SetUrlState(nsMsgMailNewsUrl * const 0x04e65e14, int 0, 
unsigned int 0) line 107
nsImapMailFolder::SetUrlState(nsImapMailFolder * const 0x02f59b20, 
nsIImapProtocol * 0x034b2560, nsIMsgMailNewsUrl * 0x04e65e14, int 0, unsigned 
int 0) line 3945 + 23 bytes
SetUrlStateProxyEvent::HandleEvent(SetUrlStateProxyEvent * const 0x04e63050) 
line 1312 + 60 bytes
nsImapEvent::imap_event_handler(PLEvent * 0x04e63054) line 76
PL_HandleEvent(PLEvent * 0x04e63054) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00a7edc0) line 508 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0ed7012c, unsigned int 49320, unsigned int 0, 
long 11005376) line 1044 + 9 bytes
USER32! 77e71820()
00a7edc0()
the message does get sent.

updating summary.  I can get the same crash if I go to forward a message, but
then close it (using the window manager X).

re-assign to putterman, until we track it down.
Assignee: rhp → putterman
Summary: crash on send of message → crash on close of message window
(Assignee)

Comment 3

17 years ago
this is a dup.


*** This bug has been marked as a duplicate of 54792 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: esther → laurel

Comment 4

17 years ago
this kind of stack trace almost always means that the assertion dialog is
pumping events, and causing code to get re-entered that does not like to be
re-entered :-)

Comment 5

17 years ago
Marking verified as duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.