menulists should use message-box font, not menu

VERIFIED FIXED in mozilla0.8

Status

SeaMonkey
Themes
P2
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Simon Fraser, Assigned: Joe Hewitt (gone))

Tracking

({modern})

Trunk
mozilla0.8
PowerPC
Mac System 8.5
modern

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Popups are using a huge, ugly font in todays tip o' the branch, modern skin. 
Screenshot coming...
(Reporter)

Comment 1

17 years ago
Created attachment 16137 [details]
Screenshot of composer popup
(Reporter)

Comment 2

17 years ago
ugly enough to need fixing for RTM, methinks.
Keywords: rtm

Comment 3

17 years ago
These are huge, I was just reporting this myself and was told about this bug.  
This is causing some of the pref panels to be larger and therefore more 
information is dropped from the panel.
Priority: P3 → P2
Whiteboard: [rtm need info]
(Reporter)

Comment 4

17 years ago
This also seriously impacts usability of mail compse. The addressing widget gets 
unusable.
(Assignee)

Comment 5

17 years ago
This problem is easily fixable.  We're using a new content model for buttons 
and menulists in order to make them scalable in 2 dimensions instead of just 
horizontally.  This involves using caps above and below the text.  The text 
can't overlay these caps, so there's an extra 7px of height.  It looks fine on 
Windows.  On the Mac, Charcoal has a larger ascent/descent than usual and so 
there's all that extra space.  I'm going to redo these bindings to use a stack 
instead.  Per discussion with Hyatt, this shouldn't affect performance.
Status: NEW → ASSIGNED
Summary: Mac modern skin: popups use a huge, ugly font → [Modern] Mac buttons/menulists are way too big
(Assignee)

Comment 6

17 years ago
In Happy News, I have a fix for this waiting in the wings.  I had to re-do the 
binding for menulists and buttons, tweak the CSS a bit, and now the buttons 
size appropriately on mac and windows.  Hopefully I'll check this in today.  
I'll post the patch as soon as I fully test it.
(Reporter)

Comment 7

17 years ago
*** Bug 55911 has been marked as a duplicate of this bug. ***
hewitt, can you include a screenshot of the "new" buttons?
(Assignee)

Comment 9

17 years ago
This is now fixed on trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
verified ok on mac (2000-10-10-MN6).
Status: RESOLVED → VERIFIED
(Reporter)

Updated

17 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 11

17 years ago
reopening. I still think they are too big.
Popups (menulists) should use the window font, not the button font, I think.
They still look pretty much like the screenshot I attached, and make the
addressing widgets in mail compose too unweildy.

Comment 12

17 years ago
Need to mark this rtm-
Whiteboard: [rtm need info] → [rtm-]
(Assignee)

Comment 13

17 years ago
Simon/Pink, I'd like to mark this fixed, as I haven't heard anybody complain
about it since RTM.  Is that kosher with you or is there still a problem?  I
just checked in a fix for bug 16729, so system fonts are now used everywhere, so
that may help.
(Assignee)

Comment 14

17 years ago
Surveys of several Mac users indicate that the buttons/menulists are sized
properly. Marking fixed.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

17 years ago
Whoa, I disagree (sorry for the delay in disagreeing!)

Popups and menulists should use the small system font by deafult (Geneva 10), and 
not the large font (Chicago 12 or whatever). Look at the addressing widget in 
mail; in Mozilla, this takes up huge amounts of space, compared to 4.x, because 
of the size of the popups. Similarly for the composer toolbar.

So make menulists and popups use the small system font by default.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED
Priority: P2 → P5

Comment 16

17 years ago
Themes Triage Team P3
Priority: P5 → P3
(Assignee)

Updated

17 years ago
Summary: [Modern] Mac buttons/menulists are way too big → [Modern] menulists should use message-box font, not menu
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 17

17 years ago
Created attachment 24000 [details] [diff] [review]
patch to fix
(Assignee)

Comment 18

17 years ago
Simon, can you please review the patch I just submitted? It should fix the
puffiness problems on buttons and menulists.
Keywords: rtm → nsbeta1
Priority: P3 → P2
Whiteboard: [rtm-]
Target Milestone: mozilla0.9 → mozilla0.8
(Reporter)

Comment 19

17 years ago
What is the "message-box" font? Is that the small application font (Geneva 10)?
Anyway, it looks *much* better. r=sfraser
(Assignee)

Comment 20

17 years ago
Yes, message-box corresponds to the "Small System Font" (Geneva), and menu
corresponds to the "Large System Font" (Charcoal) from the Appearances dialog.

Comment 21

17 years ago
a=hangas
(Assignee)

Comment 22

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
Marking verified on Mac (2001-02-05-12-Mtrunk).
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: modern

Updated

17 years ago
Summary: [Modern] menulists should use message-box font, not menu → menulists should use message-box font, not menu
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.