Can't complete single instance of recurring task from task list

VERIFIED DUPLICATE of bug 373775

Status

defect
--
major
VERIFIED DUPLICATE of bug 373775
9 years ago
9 years ago

People

(Reporter: suzie, Unassigned)

Tracking

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.8) Gecko/20100214 Ubuntu/9.10 (karmic) Firefox/3.5.8
Build Identifier: 2009100813 - on thunderbird version 2.0.0.23 (20090817) on Linux, but also on TB3 with latest calendar under windows

Can't complete single instance of recurring task from task list.

I have a recurring task set up, and I have tasks showing in calendar. If I click on an instance of the task in the calendar, and choose 'edit just this occurence' I can complete that specific instance of the task. It then disappears from the calendar - which is a minor hassle, but that's all. However, if I use tasks list view instead of the calendar, when I open the task, there is no mention of editing the single instance, and completing what looks like a single instance actually deletes the entire set of tasks.


Reproducible: Always

Steps to Reproduce:
1. create a recurring task
2. view tasks on calendar
3. complete an instance of the task via the calendar 
4. complete an instance of the task from the task list
Actual Results:  
In step 3. the single instance of the task disappears from task view. In step 4 all instances of the task disappear

Expected Results:  
In step 3. Task should stay on calendar, but show as complete
In step 4. Completed instance of task should show as completed - next instance should show.

This seems to be the same in both windows with Thunderbird 3 and latest calendar build and in Linux under Ubuntu and Kubuntu 9.10 with Thunderbird 2 and calendar 0.9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373775
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.